UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer zafirhafeez
Observer
2,867 Views
Registered: ‎05-16-2015

JTAG problem in custom board

Jump to solution
Hello,
I am in the process of a custom board bring up based on zynq XA7Z020. I am not able to detect the device on JTAG. I am using usb platform cable for the JTAG connection and vivado 2016.4. I have checked all the voltages to zynq and also the crystal frequency (50 mhz). Also the jtag signals are arriving up to the resistors connected to the zynq jtag pins (checked with oscilloscope; cannot check the signals upto the bga obviously). When I select auto connect in hardware manager the cable is detected but no device is detected on the cable. The led on platform cable turns yellow as the board is powered. SRST and POR pins are at high.
Please help me what can be the reason​ for this problem.

Thanks,
Jwd
Tags (3)
0 Kudos
1 Solution

Accepted Solutions
Observer zafirhafeez
Observer
4,763 Views
Registered: ‎05-16-2015

Re: JTAG problem in custom board

Jump to solution
I have managed to resolve the problem. The issue seemed to be with the power on sequence and reset timing. Thanks for the support
0 Kudos
3 Replies
Xilinx Employee
Xilinx Employee
2,852 Views
Registered: ‎08-01-2012

Re: JTAG problem in custom board

Jump to solution

Please check all JTAG connections as per configuration user guide. Please  reduce TCK frequency and try once

 

What is the O/S installed in your system?

 

Please check whether the below minimum PC environment was there in your system or not:

The host computer must contain a USB host controller with one or more USB ports. The controller can reside on the PC motherboard, or can be added using an expansion or PCMCIA card. Xilinx USB cables support both USB 1.1 and 2.0 ports, although performance is optimal on USB 2.0 ports. For additional details, refer to the cable data sheets: Platform Cable USB Data Sheet(DS300) and Platform Cable USB II Data Sheet(DS593):
http://www.xilinx.com/support/documentation/configuration_hardware.htm 

 

Also refer https://www.xilinx.com/support/answers/35011.html 

 

 

 

________________________________________________

Please mark this post as an "Accept as solution" in case if it helped to resolve your query. So that it will help to other forum users to directly refer to the answer.

Give kudos to this post in case if you think the information is useful and reply oriented.

0 Kudos
Observer zafirhafeez
Observer
2,844 Views
Registered: ‎05-16-2015

Re: JTAG problem in custom board

Jump to solution

Thanks for your reply. OS is Windows 7 64 bit. I will check with lower TCK frequency and get back with the result

0 Kudos
Observer zafirhafeez
Observer
4,764 Views
Registered: ‎05-16-2015

Re: JTAG problem in custom board

Jump to solution
I have managed to resolve the problem. The issue seemed to be with the power on sequence and reset timing. Thanks for the support
0 Kudos