cancel
Showing results for 
Search instead for 
Did you mean: 
Anonymous
Not applicable
9,738 Views

PROBLEM WITH UART ON CONSOLE

Jump to solution

HI,

 

I have created a simple processor based design with an uartlite ip.

I have used the hello_world template.

 

In the mss file I am using debugmodule as stdio and while debugging the application I am using the same,and it is working.

 

Now I am changing the mss file stdio to rs232_uart and changing my debug configuration accordingly.

 

Now, I am getting the following message while debugging by stepping into.

 

" Can't find a source file at "/wrk/ptx/users/nagaraju/GCC_2013_03/newlib/libgloss/microblaze/print.c"
Locate the file or edit the source lookup path to include its location."

 

 

Where am I possibly going wrong???

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Community Manager
Community Manager
15,737 Views
Registered: ‎07-23-2012

Re: PROBLEM WITH UART ON CONSOLE

Jump to solution
Please refer to https://forums.xilinx.com/t5/Embedded-Development-Tools/Can-t-find-print-c-using-SDK-12-1/td-p/73576
-----------------------------------------------------------------------------------------------
Please mark the post as "Accept as solution" if the information provided answers your query/resolves your issue.

Give Kudos to a post which you think is helpful.

View solution in original post

0 Kudos
2 Replies
Highlighted
Moderator
Moderator
9,716 Views
Registered: ‎07-31-2012

Re: PROBLEM WITH UART ON CONSOLE

Jump to solution

Hi,

 

If you are using Zynq evaluation boards where PS UART is tied with UART port.

The axi uartlite cant be connected to this port.

 

Please verify in the BSP settings -STDin and STDout fields.

 

Regards

Praveen

-----------------------------------------------------------------------------------------------
Please mark the Answer as "Accept as solution" if the information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.


-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Highlighted
Community Manager
Community Manager
15,738 Views
Registered: ‎07-23-2012

Re: PROBLEM WITH UART ON CONSOLE

Jump to solution
Please refer to https://forums.xilinx.com/t5/Embedded-Development-Tools/Can-t-find-print-c-using-SDK-12-1/td-p/73576
-----------------------------------------------------------------------------------------------
Please mark the post as "Accept as solution" if the information provided answers your query/resolves your issue.

Give Kudos to a post which you think is helpful.

View solution in original post

0 Kudos