UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor falchun
Visitor
3,855 Views
Registered: ‎08-20-2010

Problem to integrate the libraries of Xilinx to my project

Jump to solution

Hello all!

 

I hope I post in the right topic.

 

I am in internship and I am trying to integrate the libraries of Xilinx in my project. My problem is when I try to simulate my project I have these warnings :

 

# ** Warning: (vsim-3473) Component instance "ppc405_adv_i : ppc405_adv" is not bound.
#    Time: 0 ps  Iteration: 0  Region: /testbench/d3/l3/cpu__0/u0/ppc405/ppc405_0/ppc405_0  File: /home/cao/xilinx/edk_8202i/hw/XilinxProcessorIPLib/pcores/ppc405_virtex4_v1_01_a/hdl/vhdl/ppc405_virtex4.vhd

 

I don't understand why it does that, because I didn't modify this file ...

 

And I have this error too :

 

# ** Error: (vsim-13) Recompile dcm_module_v1_00_a.dcm_module(struct) because dcm_module_v1_00_a.dcm_module has changed.

 

And I tried to compile dcm_module_v1_00_a.dcm_module(struct) (even I thinked it did not change anything) I have this error :

 

# ** Error: (vsim-13) Recompile dcm_module_v1_00_a.dcm_module(struct) because dcm_module_v1_00_a.dcm_module has changed.

 

I don't know at all what I have to do :/ Somebody can help me please ?

 

 

0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
4,851 Views
Registered: ‎07-30-2007

Re: Problem to integrate the libraries of Xilinx to my project

Jump to solution

The actual powerpc is represented as a "smartmodel" encrypted library.  You likely need to follow the directions in the documentation on how to set up smartmodels for simulation.

 

Also, it sounds like your modelsim libraries are out of date.  I'd suggest rerunning the xilinx library compilation with compedk, which will also help install the smartmodels.

0 Kudos
4 Replies
Visitor falchun
Visitor
3,827 Views
Registered: ‎08-20-2010

Re: Problem to integrate the libraries of Xilinx to my project

Jump to solution

I manage to correct my errors but not my warning.

For the personn who are interested, I had these errors because I did not combine my unisim_VCOMP.vhd, my unisim_VITAL.vhd and my unisim_VPKG.vhd correctly.

0 Kudos
Visitor falchun
Visitor
3,809 Views
Registered: ‎08-20-2010

Re: Problem to integrate the libraries of Xilinx to my project

Jump to solution

I always have my warning... I really don't understand. My entity ppc405_adv appears in the library work. Normally this entity should be in the library unisim... I tried many things to correct this problem, but now, I have no more idea to correct it. :(

Somebody can help me please ?

 

edit : Sorry I forgot to say you : I use modelsim 6.5b and edk 8.2.02

0 Kudos
Xilinx Employee
Xilinx Employee
4,852 Views
Registered: ‎07-30-2007

Re: Problem to integrate the libraries of Xilinx to my project

Jump to solution

The actual powerpc is represented as a "smartmodel" encrypted library.  You likely need to follow the directions in the documentation on how to set up smartmodels for simulation.

 

Also, it sounds like your modelsim libraries are out of date.  I'd suggest rerunning the xilinx library compilation with compedk, which will also help install the smartmodels.

0 Kudos
Visitor falchun
Visitor
3,784 Views
Registered: ‎08-20-2010

Re: Problem to integrate the libraries of Xilinx to my project

Jump to solution

Thank you for your answer.I reran the xilinx library compilation with compedk how you suggested me and it was that.

Thank you again ;)

 

0 Kudos