UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
3,019 Views
Registered: ‎06-01-2011

Problems with MPMC on Virtex5 device

I have a board from HiTechGlobal with Virtex 5 FX200T Devices.

I must use the external memory (SODIMM MT16HTF25664HY-667E1) shared between 2 PPCs.

I use the MPMC 6.02.a with the integrated MIG interface connected via PLB (@100MHz) to 2 PPCs(@400MHz).

During the MPMC settings I have:

1) I run the BITSTREAM generation and the process ends without errors

2) I create the SDK application

3) I initialize the MPMC interface without errors:

MiaMpmc_Config = XMpmc_LookupConfig(XPAR_MPMC_0_DEVICE_ID);

if (XMpmc_CfgInitialize(&MiaMpmc, MiaMpmc_Config, MiaMpmc_Config->BaseAddress)!= XST_SUCCESS)
{ xil_printf("\r\nUnable to initialize MPMC");
while (1);
}

4) I run the MPMC Self Test without errors:

if (XMpmc_SelfTest(&MiaMpmc)!= XST_SUCCESS)
{ xil_printf("\r\nSelf Test MPMC failed");
while (1);
}


But I have the following problem:

if I try to access to the memory via application the memory does't respond.

I use the following code:

Read_Value=Xil_In32(XPAR_MPMC_0_MPMC_BASEADDR);

Xil_Out32(XPAR_MPMC_0_MPMC_BASEADDR, 0x12345678);

Read_Value=Xil_In32(XPAR_MPMC_0_MPMC_BASEADDR);

And Read_Value assumes always the same value (0xwith or without the SODIMM memory (0xa5a5a5a5)


Can you help me to resolve the problem?

 

I use SDK 12.4

0 Kudos
3 Replies
Xilinx Employee
Xilinx Employee
3,007 Views
Registered: ‎03-18-2008

Re: Problems with MPMC on Virtex5 device

Since this is a embedded applications issue, this question would be best answered in the embedded forums. I'll send this over there instead
0 Kudos
Xilinx Employee
Xilinx Employee
2,998 Views
Registered: ‎08-01-2007

Re: Problems with MPMC on Virtex5 device

have your checked the mpmc init_done signal?
does it assert?
0 Kudos
2,992 Views
Registered: ‎06-01-2011

Re: Problems with MPMC on Virtex5 device

@joshualu: No the init_done signal remains low.

0 Kudos