UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor rtapiador
Visitor
355 Views
Registered: ‎06-07-2018

Reset PL from Petalinux Zynq MPSoC

Hi all,

I am triying to reset the PL from PS using petalinux.

My first attemp was using GPIO, However the system gets hangs when I tried to write a 1 to enable the reset.

Then I tried to use the ZynqMp reset driver to reset the PL reset, I did everything that I read here:

https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18842455/ZynqMP+Linux+Reset-controller+Driver

However the reset-mgr is not listed. I enabled the reset driver, but I have some doubts about where to write the dts entry. I wrote in /project-spec/meta-user/recipes-bsp/device-tree/files/system-user.dtsi
This is the entry:

rst: reset-controller {
compatible = "xlnx,zynqmp-reset";
#reset-cells = <1>;
};

I need to reset the logic and I would like to know if i wrote wrongly the dts entry or why the GPIO hangs the system.

If there is another way to reset the logic please tell me.

Thanks in advance

0 Kudos