UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Explorer
Explorer
319 Views
Registered: ‎01-15-2008

SDK2018.3 with Windows 10

Hi all,

I got a new Win10 (Pro 64bit) PC.  Have transferred a mature project from my Win7 box, on which I was using Vivado/SDK2017.4.  Have worked on this project there for months.

Installed Viv/SDK2018.3 on Win10 box.  Successfully compiled hardware under Viv2018.3, after upgrading all IP, etc.  Successfully compiled Microblaze software under SDK2018.3.  So far so good.

(It was necessary to stop "Windows Defender" Real-time protection to stop very bizarre crashing and locking up issues with SDK on Win10)

hardware is a custom board, no DRAM (so all SW fits in 256kB BRAM). JTAG connection through platform cable DLC9LP.

With Win7/SDK2017.4 I can program FPGA with bitfile + bootloop, then load elf, all good.  Then I can combine bitfile and elf in one download.bit, load it up, runs fine.  Can then make boot image, load flash.  All good

 

With Win10/SDK2018.3 I can program FPGA with bitfile + bootloop, then load elf, all good. When I combine the bitfile and elf and load it up, no go.  The FPGA is obviously being loaded, as it takes the right amount of time and the supply current increases appropriately at the end.  But the code doesn't run.

 

I tried taking the download.bit generated by the Win7 system and loading it up via the Win10 one, and it works, so it seems the download.bit is not being correctly generated on the Win10.

Here's the console output when I program the bitfile + elf on the Win10 system:

Capture.JPG

 

Very similar to the output under Win7, with appropriate version changes.

I'll be grateful for any help; would like to get my work back together on one PC!

Thanks

Rick

 

0 Kudos
1 Reply
Explorer
Explorer
270 Views
Registered: ‎01-15-2008

Re: SDK2018.3 with Windows 10

I see that this problem has been understood by another contributor; it's a problem in the .mmi file.  See this post:

https://forums.xilinx.com/t5/Embedded-Development-Tools/Vivado-2018-3-Updatemem-strange-behavior-in-endianness/m-p/928937/highlight/false#M48003

 

0 Kudos