We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Showing results for 
Search instead for 
Did you mean: 
Visitor aashwin
Registered: ‎07-10-2017

Simple simulation

Hi all,


What I'm trying to do:

  • Using the blog series by Adam Taylor on the microzedv (issue 30 - 37), I'm trying to drive some neopixels LEDS using the PL.
    • I'm not actually using a microzed but a te0728 from Trenz Electronics
  • This is the block diagram I'm trying to implement
  • image.png
  • PS writes to bram the number of leds and corresponding RGB values for each LED and neo_pixel driver reads from bram and outputs (dout) to the LEDS
  • Using some sample code from the blog, I'm trying to run a simple simulation to see the waveform of dout

What I've tried:

  • To create the neo_pixel ip, I created a new project with the VHDL source for neopixel driver and the testbench (see attached) and packaged it to use in main project
  • However when I try to run behavorial simulation in the neopixel driver projection I do not see the dout value changing. It just stays '0'
    • image.png 
    • I suspect that it has to do with the testbench using the 'uzed_blk_mem_gen' entity which doesn't exist? How can I make this entity? Just by adding a lone bram generator in the block diagram?

As you can tell I'm clearly new to this. If you can give me some advice or point me to some resources that would be great.



0 Kudos
2 Replies
Teacher muzaffer
Registered: ‎03-31-2012

Re: Simple simulation

@aashwin Did you duplicate the block diagram carefully? do you have the two pieces in the bottom center of the image you show? (bram controller and blk mem gen) 

- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
0 Kudos
Visitor aashwin
Registered: ‎07-10-2017

Re: Simple simulation

I should have added that this is now solved.


I was in the project for the 'neo_pixel' ip block, the problem was the block mem was not in the project. Simply went to IP catalog, inserted the block memory, used the instantiation template. After this all was well.


Thanks for the reply.



0 Kudos