UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
509 Views
Registered: ‎01-09-2019

Vertex 5 Temac showing RX packet rejected

Jump to solution

hi..

i am using vertex 5 hard Temac for ethernet communication.i am tryint to send ethernet data as per ethernet 802.3 standard where ip address is not a part of the packet.

i am able to send the data from the FPGA to PC but when i am trying to receive the packet it is showing RX packet rejected interrupt.but i am able to receive udp packet from the PC without any issue.

TR890402.jpg
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Voyager
Voyager
466 Views
Registered: ‎02-01-2013

Re: Vertex 5 Temac showing RX packet rejected

Jump to solution

According to the spec, setting bit 25 of the Receiver Configuration (Word 1) register will disable Length/Type checking on inbound packets.

2019-01-10_22-17-44.jpg

2019-01-10_22-18-14.jpg

Alternatively, you can set the attribute (below) of the instantiation in your hardware, and that should carry into the design and become the default value of the register bit.

2019-01-10_22-20-40.jpg

-Joe G.

0 Kudos
5 Replies
Voyager
Voyager
477 Views
Registered: ‎02-01-2013

Re: Vertex 5 Temac showing RX packet rejected

Jump to solution

Where's the packet?  Show us the packet that gets rejected.

If you disable the Length/Type check, does the packet still get rejected?

Are you capturing all of the Rx stats?  Do they contain any additional information as to the reason for the rejection?

-Joe G.

 

0 Kudos
471 Views
Registered: ‎01-09-2019

Re: Vertex 5 Temac showing RX packet rejected

Jump to solution

thanks for the reply.

i am preparing the packet as per the attached image.means first 6 byte are dest mac addr,then next 6 byte are source mac addr,then 2 bytes are data length and rest all are zero..i am sending 90 bytes in total...i am using 2 temac..both are connected via a lan cable.from one temac i am transmitting and in 2nd temac i am receiving..when i am debuging Temacerrorhandler function is called and there it is showing RXpacket Rejected error.can you pls give some demo code on how to disable length check or address filtering for the temac..

thank you

0 Kudos
Highlighted
Voyager
Voyager
467 Views
Registered: ‎02-01-2013

Re: Vertex 5 Temac showing RX packet rejected

Jump to solution

According to the spec, setting bit 25 of the Receiver Configuration (Word 1) register will disable Length/Type checking on inbound packets.

2019-01-10_22-17-44.jpg

2019-01-10_22-18-14.jpg

Alternatively, you can set the attribute (below) of the instantiation in your hardware, and that should carry into the design and become the default value of the register bit.

2019-01-10_22-20-40.jpg

-Joe G.

0 Kudos
450 Views
Registered: ‎01-09-2019

Re: Vertex 5 Temac showing RX packet rejected

Jump to solution

i will implement and come back to you..thanks

0 Kudos
404 Views
Registered: ‎01-09-2019

Re: Vertex 5 Temac showing RX packet rejected

Jump to solution

thanks ...it worked..

0 Kudos