UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer paul_paul
Observer
4,764 Views
Registered: ‎09-06-2013

where to increase timeout for download large files before starting the program using TCF debugger?

Jump to solution

Hi! I use download files before launching the program for debug using this feature:

download_data_to_mb_mem_using_jtag.gif

 

But my filesize is too large (several tens of megabytes) and during download the timeout occurs with this error:

ERROR : Timeout occured while waiting to get reply for command "xdownload 0 -data D:/paul/svn_fft/fpga/sim/data/fft_twd.bin 0xa8000000"

Really there is no error because it's ok to wait so long time because the file is large.

But where to increase the timeout to avoid such error?

0 Kudos
1 Solution

Accepted Solutions
Scholar sampatd
Scholar
8,136 Views
Registered: ‎09-05-2011

Re: where to increase timeout for download large files before starting the program using TCF debugger?

Jump to solution

Try this:

 

Windows-> Preferences -> Xilinx SDK -> XMD Startup

 

BTW, which version of SDK are you using?

View solution in original post

2 Replies
Scholar sampatd
Scholar
8,137 Views
Registered: ‎09-05-2011

Re: where to increase timeout for download large files before starting the program using TCF debugger?

Jump to solution

Try this:

 

Windows-> Preferences -> Xilinx SDK -> XMD Startup

 

BTW, which version of SDK are you using?

View solution in original post

Observer paul_paul
Observer
4,737 Views
Registered: ‎09-06-2013

Re: where to increase timeout for download large files before starting the program using TCF debugger?

Jump to solution

Many thanks! Your suggestion works! The timeout was 1 minute, I changed to 10 minutes.

0 Kudos