cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
660 Views
Registered: ‎05-18-2018

SDAccel 2018.2 batch installation compiling sdaccel examples

Hi

I did the batch mode installation of SDAccel. I Setup the following environment variables, and clone the SDAccel examples 2018.2. krnl_vadd.xclbin is not created.

In another setup; running Ubuntu 16.04 desktop, the same example is compiled using the eclipse environment -using SDX), I see that a folder by name Emulation-SW or Emulation-HW gets created and the krnl_vadd.xclbin getting created, with the same 'vector add' example.

PS: The following are the environment variables that I set, as we have command only interface (no xserver running) in the servers - we are using Ubuntu 16.04 server

export LM_LICENSE_FILE=/opt/Xilinx/License/Xilinx.lic
export XCL_EMULATION_MODE=sw_emu

export XILINX_VIVADO=/opt/Xilinx/Vivado/2018.2
export LD_LIBRARY_PATH =$XILINX_VIVADO/ids_lite/ISE/lib/lin64:$LD_LIBRARY_PATH

source /opt/Xilinx/SDx/2018.2/settings64.sh

git clone https://github.com/Xilinx/SDAccel_Examples.git sdaccel_example -b 2018.2

cd <pathtogSDAccel_Example>getting_started/misc/vadd

make all TARGET=sw_emu DEVICE=Xilinx_vcu1525_dynamic_5_1

The above command only creates the vadd executable and no krnl_vadd.xclbin

Is there any other environment variables to set?

0 Kudos
2 Replies
Highlighted
Moderator
Moderator
599 Views
Registered: ‎07-16-2008

Did you observe any errors in running the makefile to build the design?

The .xclbin file should be generated in /xclbin directory within the <pathtogSDAccel_Example>getting_started/misc/vadd.

BTW, the variable for changing the platform should be DEVICES.

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Highlighted
Visitor
Visitor
589 Views
Registered: ‎05-18-2018

Hi

Thanks for your quick response. The file krnl_vadd.sw_emu.Xilinx_vcu1525_dynamic_5_1.xclbin is created in the xclbin folder

 

Now, when I execute the vadd example as below

$ ./vadd xclbin/krnl_vadd.sw_emu.Xilinx_vcu1525_dynamic_5_1.xclbin

or

Just

$ ./vadd

../../..//libs/xcl2/xcl2.cpp:40 Error calling err = cl::Platform::get(&platforms), error code is: -1001

I get the above error message. Am I missing something here. Any Environment variables or Path to be set. Please note: I am executing this from the terminal and do not have the option of using sdx (GUI environment) as we are executing on Ubuntu server.

Thanks

Venkatesh Lakshmikanthan

0 Kudos