cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Visitor
Visitor
968 Views
Registered: ‎12-01-2017

SDAccel to continue generating the bitstream even if the timing requirement is not met?

Is there a way to let SDAccel continue generating the bitstream even if the timing requirement is not met?
 
My RTL kernel uses the system clock as the main clock and the critical path only fails timing by a very small negative slack.  Then the xocc link step errors out right before bitstream generation, after hours of P&R...   I think the bitstream would still work given the small WNS.
 
Alternatively, is there a way lower the system clock (something similar to the xocc option "--kernel_frequency" but for system clock)?
0 Kudos
Reply
6 Replies
Xilinx Employee
Xilinx Employee
938 Views
Registered: ‎03-24-2010

SDAccel doesn't allow bitstream if timing fails in non-scalable region.  

There's no option to release timing for non-kernel logic. But if you use --kernel_frequency to lower the timing of your kernel, it's still helpful for timing in non-kernel logic.

Regards,
brucey
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Reply
Contributor
Contributor
924 Views
Registered: ‎05-11-2018

Hi,@brucey ,

In one of my design , at beginning i set --kernel_frequency to 250  and 200 ,both cannot generate bitstream because of timing. 

However, when I set to 230MHz, the sdaccel auto changed the frequency to 206MHz and successfully generated bitstream. 

My question is , why the implementation succeed at 230MHz rathan than 200MHz ?  

0 Kudos
Reply
Moderator
Moderator
864 Views
Registered: ‎11-04-2010

Hi, @yanhan ,

Could you try to run the design again in SDx 2018.3?

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Reply
Contributor
Contributor
848 Views
Registered: ‎05-11-2018

Hi, @hongh , 

Several problems occured after I installed the SDx 2018.3 

1. In vivado_hls , if I click 'stop C synthesis' , the network would be disconnected and all programs, even including all the tmux sessions, would get  abnormal shutdown.  

The computer status was just like rebooted before and nothing ran except the OS. 

2. I cannot assign slr for my kernels cause the '--slr ' link option is not supported kcu1500 board. 

Do you know how to solved them ?  My OS is Ubuntu 16.04.5 LTS. 

Thanks.  

0 Kudos
Reply
Moderator
Moderator
815 Views
Registered: ‎11-04-2010

Hi, @yanhan ,

1. For the hls issue, please post in HLS board.

2. Refer to UG1238, the supported operating system is:

Linux, 64-bit:
• Ubuntu 16.04.4, 18.04
• CentOS 7.4, 7.5
• RHEL 7.4, 7.5

For "--slr option failing to work in KCU1500" issue, please create a new thread.

 

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Reply
Moderator
Moderator
803 Views
Registered: ‎08-20-2018

Hi @lannylian

Please refer below link,

https://www.xilinx.com/html_docs/xilinx2018_2/sdaccel_doc/system-options-gbs1504034400961.html

You can use below linker option

param:compiler.skipTimingCheckAndFrequencyScaling=1

Please add xp parameter in GUI as mentioned below.

sds++ -xp param:compiler.skipTimingCheckAndFrequencyScaling=1 -xp "vivado_prop:run.impl_1.{STEPS.PHYS_OPT_DESIGN.ARGS.MORE OPTIONS}={-directive Explore}" -xp "vivado_prop:run.impl_1.{STEPS.ROUTE_DESIGN.ARGS.MORE OPTIONS}={-directive Explore}"

skip_time_param.png

Best Regards,
Nutan
-------------------------------------------------------------------------------
Please don't forget to reply, kudo and accept as a solution
0 Kudos
Reply