UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Participant tuanho27
Participant
233 Views
Registered: ‎03-28-2018

Cannot create new SDSoC platform with existing interrupt Concat

Hi all,

 

I have tried to create a new SDSoC platform on ZC706 using 2018.2 tool version (re-use the TRD 2015.4 design);

However, this block design already exists the interrupts for HDMI and TPG which connect directly IRQ_F2P through a Concat IP.

As I refer the UG1146, the platform needs the interrupt interface which also connects to a Concat IP and uses the least significant bits of the IRQ_F2P port.

So I tried to add an AXI interrupt (new IP block) for the HDMI and TPG interrupt sources and connect the output to Core0_nIRQ, then let the IRQ_F2P 

connect to the available Concat IP as the suggest from UG (image 1)

But, this design cannot make the petalinux to successfully create the device-tree for axi_vdma (inside HDMI and TPG design) (image 2),

I have commented the *.tcl script for the build process continues, it seems that petalinux can finish but after that when I try to build the motion detect example on SDSoC and boot the system from SDcard, the system cannot finish booting process with a message that  DMA initialization failed (image 3)

I know something wrong in the design using AXI_INTC IP block for HDMI &TPG output interrupt instead of connecting to IRQ directly, but I wonder that is this way will work for the SDSoC platform, is there any other ways to handle this (new platform with existing interrupt in the design), and will the design platform lacks interrupt interface cause the issue later?

Selection_157.png
Selection_158.png
Selection_155.png
0 Kudos