UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer sbuschjaeger
Observer
4,917 Views
Registered: ‎07-29-2015

Cannot create new SDSoC project

Hi,

 

I'm not able to create a new SDSoC project on ubuntu 16.04 with SDSoC Version 2015.4 (64 bit)

When clicking on "create new SDSoC project" nothing happens. The log file shows me:

 

!SESSION 2016-08-02 18:26:44.065 -----------------------------------------------
eclipse.buildId=2015.4
java.version=1.8.0_45
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86_64

!ENTRY org.eclipse.ui 4 0 2016-08-02 18:27:07.628
!MESSAGE Unhandled event loop exception
!STACK 0
java.lang.NullPointerException
        at com.xilinx.sdsoc.ui.wizard.SDSProjectMainComposite.validatePlatformFile(SDSProjectMainComposite.java:226)
        at com.xilinx.sdsoc.ui.wizard.SDSProjectMainComposite.selectValidPlatform(SDSProjectMainComposite.java:122)
        at com.xilinx.sdsoc.ui.wizard.SDSProjectMainComposite.<init>(SDSProjectMainComposite.java:74)
        at com.xilinx.sdsoc.ui.wizard.SDSProjectWizardPage.createControl(SDSProjectWizardPage.java:33)
        at org.eclipse.jface.wizard.Wizard.createPageControls(Wizard.java:174)
        at org.eclipse.jface.wizard.WizardDialog.createPageControls(WizardDialog.java:736)
        at org.eclipse.jface.wizard.WizardDialog.setWizard(WizardDialog.java:1182)
        at org.eclipse.jface.wizard.WizardDialog.updateForPage(WizardDialog.java:1241)
        at org.eclipse.jface.wizard.WizardDialog.access$4(WizardDialog.java:1238)
        at org.eclipse.jface.wizard.WizardDialog$8.run(WizardDialog.java:1227)
        at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
        at org.eclipse.jface.wizard.WizardDialog.showPage(WizardDialog.java:1225)
        at org.eclipse.jface.wizard.WizardDialog.nextPressed(WizardDialog.java:915)
        at org.eclipse.jface.wizard.WizardDialog.buttonPressed(WizardDialog.java:428)
        at org.eclipse.jface.dialogs.Dialog$2.widgetSelected(Dialog.java:628)
        at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:248)
        at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
        at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1392)
        at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3742)
        at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3363)
        at org.eclipse.jface.window.Window.runEventLoop(Window.java:826)!SESSION 2016-08-02 18:26:44.065 -----------------------------------------------
eclipse.buildId=2015.4
java.version=1.8.0_45
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86_64

!ENTRY org.eclipse.ui 4 0 2016-08-02 18:27:07.628
!MESSAGE Unhandled event loop exception
!STACK 0
java.lang.NullPointerException
        at com.xilinx.sdsoc.ui.wizard.SDSProjectMainComposite.validatePlatformFile(SDSProjectMainComposite.java:226)
        at com.xilinx.sdsoc.ui.wizard.SDSProjectMainComposite.selectValidPlatform(SDSProjectMainComposite.java:122)
        at com.xilinx.sdsoc.ui.wizard.SDSProjectMainComposite.<init>(SDSProjectMainComposite.java:74)
        at com.xilinx.sdsoc.ui.wizard.SDSProjectWizardPage.createControl(SDSProjectWizardPage.java:33)
        at org.eclipse.jface.wizard.Wizard.createPageControls(Wizard.java:174)
        at org.eclipse.jface.wizard.WizardDialog.createPageControls(WizardDialog.java:736)
        at org.eclipse.jface.wizard.WizardDialog.setWizard(WizardDialog.java:1182)
        at org.eclipse.jface.wizard.WizardDialog.updateForPage(WizardDialog.java:1241)
        at org.eclipse.jface.wizard.WizardDialog.access$4(WizardDialog.java:1238)
        at org.eclipse.jface.wizard.WizardDialog$8.run(WizardDialog.java:1227)
        at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
        at org.eclipse.jface.wizard.WizardDialog.showPage(WizardDialog.java:1225)
        at org.eclipse.jface.wizard.WizardDialog.nextPressed(WizardDialog.java:915)
        at org.eclipse.jface.wizard.WizardDialog.buttonPressed(WizardDialog.java:428)
        at org.eclipse.jface.dialogs.Dialog$2.widgetSelected(Dialog.java:628)
        at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:248)
        at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
        at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1392)
        at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3742)
        at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3363)
        at org.eclipse.jface.window.Window.runEventLoop(Window.java:826)

 

There seems to be a related problem with different installation folders (https://forums.xilinx.com/t5/SDSoC-Development-Environment/Can-t-create-an-SDSoC-Project/td-p/706841), but I use the standard folders:

 

[18:28:05]/opt/Xilinx/SDSoC/2015.4/bin$ pwd
/opt/Xilinx/SDSoC/2015.4/bin
[18:28:06]/opt/Xilinx/SDSoC/2015.4/bin$ ./sdsoc

An my workspace is located at in:

/home/sbuschjaeger/Desktop/sdsoc-workspace

I already tried to install a newer version of SDSoC, but there seems to be a problem with the download. Does anybody have an idea how to get 2015.4 running?

 

Thanks

0 Kudos
7 Replies
Xilinx Employee
Xilinx Employee
4,912 Views
Registered: ‎06-29-2015

Re: Cannot create new SDSoC project

Hi sbuschjaeger,

 

Which platform are you trying to make a project for? Is it a custom platform or one of the defaults (zc702/zed/etc...)?


Sam

0 Kudos
Scholar trenz-al
Scholar
4,904 Views
Registered: ‎11-09-2013

Re: Cannot create new SDSoC project

why do you want 2015.4 ?? 2016.2 SDSoC is released!

0 Kudos
Observer sbuschjaeger
Observer
4,882 Views
Registered: ‎07-29-2015

Re: Cannot create new SDSoC project

@sskalick I dont get that farI can select "SDSoC Project" in the "New Project" wizard. But when I click on "next" nothing happens and the error message is generate in the log file.

 

@trenz-al I have 2015.4 installed and the web installer for 2016.2 is not working at the moment because "some file are missing on the server". But I'm currently downloading the whole 7GB iso file which takes ages...

0 Kudos
Xilinx Employee
Xilinx Employee
4,878 Views
Registered: ‎06-29-2015

Re: Cannot create new SDSoC project

Hi sbuschjaeger,

 

Can you select File -> New -> SDSoC Project from the menu bar. Does the New Project Wizard open? Or do you get an error?

 

Sam

 

 

0 Kudos
Observer sbuschjaeger
Observer
4,876 Views
Registered: ‎07-29-2015

Re: Cannot create new SDSoC project

Hi @sskalick

 

Nothing happens. Same error.

0 Kudos
Xilinx Employee
Xilinx Employee
4,873 Views
Registered: ‎06-29-2015

Re: Cannot create new SDSoC project

Hi ,

 

Im not really sure what the problem is, but 2015.4 only officially supported Ubuntu Linux 14.04.2 LTS (64-bit). Heres a link to the release notes.

 

http://www.xilinx.com/support/documentation/sw_manuals/xilinx2015_4/ug1185-sdsoc-release-notes.pdf

 

Sam

0 Kudos
Xilinx Employee
Xilinx Employee
4,859 Views
Registered: ‎07-13-2012

Re: Cannot create new SDSoC project

If you are not using a new workspace, try that in case the one you're using became corrupted. Make sure

the workspace is not in the SDSoC installation folder and you are not starting sdsoc from within an installation folder.

Confirm you have write permission in the workspace.

 

If you continue to see problems, you can try enabling diagnostic messages. Before using File > New > SDSoC Project,

open the Windows > Preferences dialog, expand the Xilinx SDSoC entry, click on Log Information, and select Log Level TRACE.

Try File > New > SDSoC Project and see if the SDSoC Log view in the lower right hand corner contains error messages

and post them to the forum.

 

SDSoC 2016.2 officially supports Ubuntu 14.04.3 LTS http://www.xilinx.com/support/documentation/sw_manuals/xilinx2016_2/ug1185-sdsoc-release-notes.pdf

and you might possibly run into issues using Ubuntu 16.04.

 

 

0 Kudos