UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer pr871
Observer
164 Views
Registered: ‎05-31-2018

How to include libsds_lib.so in root file system?

I've just created a custom platform project in SDSoC with prebuilt SW and HW components. From UG1146 regarding the library libsds_lib.so:

"Platform developers should be aware that this previously statically linked library is now a dynamically linked library that must be included in the Linux file system image that runs on the board."

I followed the steps in UG1144, Chapter 7, Including Prebuilt Libraries, where I made a sample application project "mylib" and changed the mylib.bb file according to the documentation. When I run petalinux-config -c rootfs, I can see that this application is included. If I check the sysroot/usr/lib directory on my host machine, I can see that the library is included as well. However, when I run a C program that was built off this custom platform, it's unable to find this library at runtime. What have I missed so that the library is included in the root file system when it's built? I can't find libsds_lib.so anywhere on the embedded Linux file system.

I'm using a Zynq Ultrascale+ MPSoC and version 2018.3 for all tools.

0 Kudos