We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Showing results for 
Search instead for 
Did you mean: 
Observer ruhul
Registered: ‎05-03-2016

bilateral - File I/O sample application build failed

Hi ...
My environmental info is -
1. OS                                                 ----  Windows 10 professional
2. SDSoC Version                             ----  2018.2
3. SDSoC License generation years ----  2018
4. reVISION platform                         ----  zcu102-rv-ss-2018-2
5. Env. Path : SYSROOT                  ----  C:/design/zcu102-rv-ss-2018-2/petalinux/sdk/sysroots/aarch64-xilinx-linux

I tried to build bilateral - File I/O sample application of zcu102-rv-ss-2018-2 reVISION platform
according to the following link - 
1. Using reVISION Samples on the reVISION Platform and  2. reVISION Getting Started Guide 2018.2 section 6.3
but build failed in both case showing following errors -

****** vpl v2018.2 (64-bit)
**** SW Build 2258646 on Thu Jun 14 20:03:12 MDT 2018
** Copyright 1986-2018 Xilinx, Inc. All Rights Reserved.

Attempting to get a license: ap_opencl
Feature available: ap_opencl
INFO: [VPL 60-895] Target platform: C:/design/zcu102-rv-ss-2018-2/zcu102_rv_ss\zcu102_rv_ss.xpfm
INFO: [VPL 60-423] Target device: zcu102_rv_ss
INFO: [VPL 60-1032] Extracting DSA to C:/xfOpenCV_project/Bilateral_Filter/Release/_sds/p0/vivado/.local/dsa
INFO: [VPL 60-251] Hardware accelerator integration...

===>The following messages were generated while Compiling (bitstream) accelerator binary: bin Log file: C:/xfOpenCV_project/Bilateral_Filter/Release/_sds/p0/vivado/prj/prj.runs/impl_1/runme.log :
ERROR: [VPL 17-69] Command failed: This design contains one or more cells for which bitstream generation is not permitted:
zcu102_rv_ss_i/hdmi_input/v_hdmi_rx_ss_0/inst/v_hdmi_rx/inst (bd_20b8_v_hdmi_rx_0__v_hdmi_rx_v3_0_0)
If a new IP Core license was added, in order for the new license to be picked up, the current netlist needs to be updated by resetting and re-generating the IP output products before bitstream generation.
ERROR: [VPL 60-704] Integration error, problem implementing dynamic region, write_bitstream ERROR
ERROR: [VPL 60-806] Failed to finish platform linker
ERROR: [SdsCompiler 83-5019] Exiting sds++ : Error when calling 'C:/Xilinx/SDx/2018.2/bin/vpl --iprepo C:/xfOpenCV_project/Bilateral_Filter/Release/_sds/iprepo/repo --iprepo C:/Xilinx/SDx/2018.2/data/ip/xilinx --platform C:/design/zcu102-rv-ss-2018-2/zcu102_rv_ss/zcu102_rv_ss.xpfm --temp_dir C:/xfOpenCV_project/Bilateral_Filter/Release/_sds/p0 --output_dir C:/xfOpenCV_project/Bilateral_Filter/Release/_sds/p0/vpl --input_file C:/xfOpenCV_project/Bilateral_Filter/Release/_sds/p0/.xsd/top.bd.tcl --target hw --save_temps --kernels w0_xf_bilateralFilter:adapter --webtalk_flag SDSoC --remote_ip_cache C:/xfOpenCV_project/ip_cache --xp \"param:compiler.deleteDefaultReportConfigs=false\" '
sds++ log file saved as C:/xfOpenCV_project/Bilateral_Filter/Release/_sds/reports/sds.log
ERROR: [SdsCompiler 83-5004] Build failed

make: *** [Bilateral_Filter.elf] Error 1

I have loaded SDSoC license according to "Voucher Redemption and Software License Key Installation Guide" UG1042 
Have tried this link of same problem but failed to solve and don't know how to regenerate License again.

My generated License Detail is

License_info.PNGSDSoC License

If further information is need, please let me know and help me to solve this problem.

Thanks in advance...

0 Kudos