UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer galina92
Observer
133 Views
Registered: ‎04-17-2015

Alignment with user defined comma

Hello!

I need to use user defined comma value for data alignment (the value is "fb"). After data is already aligned, i connect ENPCOMMAALIGN and ENMCOMMAALIGN to 0. But at the moment my channel alignment sequence is changed to usual data, the alignment is lost. I think, it is because there are bytes, equal to comma in data stream... How can I solve this problem?

When I were using a valid comma value K28.5, there was not such kind of problem.

 

I use 7 series transceivers wizard 3.6.

0 Kudos
1 Reply
Moderator
Moderator
40 Views
Registered: ‎07-30-2007

Re: Alignment with user defined comma

Is 8B10B enabled in your channel or have you switched to raw data?  Your scheme could work with raw data but in either case you have to make sure there is no FB in the datastream either aligned or misaligned.  If you are using 8B10B you need to make sure you specified the characters properly.  It can be confusing so read that section of the UG carefully.  Make sure your scheme works in simulation.  Simulation will be the best platform for debug. 

Roy


----------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution
----------------------------------------------------------------------------


0 Kudos