UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
342 Views
Registered: ‎12-18-2018

GT-Debugger Eye-Qualification

Jump to solution

Hello everyone,

 

I have been trying to perform the eye-qualification of a transmission link using GT-Debugger and IBERT+ following the guide found here: AR# 70915.

But I have encountered some problems.

Every time I run the commands from the TCL Console from the Vivado GUI, it tells me that rxout_div is not known in the dictionary, even though it has been sourced from the file insert_gt_dbg_hwproc.tcl

error_GT-debugger.PNGGiving this error

I am working with a VCU118ES-1, with 8 12.5Gbs, bidirectional link.

Is anyone having the same problem, or found any possible solution?

Thank you in advance for your help

 

0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
300 Views
Registered: ‎10-19-2011

Re: GT-Debugger Eye-Qualification

Jump to solution

Hi @alessandro.ottino,

your init step did not finish correctly. For GTY you would need to tell the tool if your line rate is higher or lower than 10Gbps as there are different settings necessary in both cases.

As you run with 12.5Gbps your init command should look like this:

igd_eyescan init cX0Y28 gty_linerate_smaller10=0

With this the run should be possible.

------------------------------------------------------------------------------
Don't forget to reply, give kudo and accept as solution
------------------------------------------------------------------------------
2 Replies
Xilinx Employee
Xilinx Employee
301 Views
Registered: ‎10-19-2011

Re: GT-Debugger Eye-Qualification

Jump to solution

Hi @alessandro.ottino,

your init step did not finish correctly. For GTY you would need to tell the tool if your line rate is higher or lower than 10Gbps as there are different settings necessary in both cases.

As you run with 12.5Gbps your init command should look like this:

igd_eyescan init cX0Y28 gty_linerate_smaller10=0

With this the run should be possible.

------------------------------------------------------------------------------
Don't forget to reply, give kudo and accept as solution
------------------------------------------------------------------------------
235 Views
Registered: ‎12-18-2018

Re: GT-Debugger Eye-Qualification

Jump to solution

Thank you so much for your help.

 

Now it works as it should

0 Kudos