cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
531 Views
Registered: ‎10-01-2019

Vivado Simulator 2019 runs forever for GTY transceiver example project

Hi All,

I have created a project using Vivado IDE for GTY transceivers. Further for simulating it, I ran the steps given in the documentation for example project. This exmaple project was also successfully created and when I run simulation, it runs for ever without the link success flag as part of simulation?

Have you folks run into any issue similar to this? Further any clue as what is to be done for this to resolve this issue?

 

Regards

Hariharan K Srinivasan.This is the snapshot from Xilinx DocumentationThis is the snapshot from Xilinx DocumentationThis is my run from Vivado simulatorThis is my run from Vivado simulator

0 Kudos
5 Replies
Highlighted
Explorer
Explorer
449 Views
Registered: ‎03-16-2019

Re: Vivado Simulator 2019 runs forever for GTY transceiver example project

this signal is latched, you should clear it after everything is going fine.

 

----------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution
----------------------------------------------------------------------------

Highlighted
Xilinx Employee
Xilinx Employee
420 Views
Registered: ‎08-07-2007

回复: Vivado Simulator 2019 runs forever for GTY transceiver example project

hi @harisrini 

 

does TXRESETDONE and RXRESETDONE go high?

 

thanks,

Boris

------------------------------------------------------------------------------
Don't forget to reply, give kudo and accept as solution
------------------------------------------------------------------------------
Highlighted
Adventurer
Adventurer
389 Views
Registered: ‎08-01-2017

Re: Vivado Simulator 2019 runs forever for GTY transceiver example project

The problem may exist for two reasons.

1. The GT reset sequence is not completed successfully. (it could be monitored through TXRESETDONE and RXRESETDONE and RXPMARESETDONE and TXPMARESETDONE)

2. The loopback is not vorrectly established. (this could be checked as if the PRBS generator/checker works correct and loopback connectivity is well established)

Highlighted
Moderator
Moderator
356 Views
Registered: ‎07-30-2007

Re: Vivado Simulator 2019 runs forever for GTY transceiver example project

In addition, there are other things that can slow down the whole process.  I would run for a full 3 milliseconds to make sure it was stuck.




----------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution
----------------------------------------------------------------------------


Highlighted
Visitor
Visitor
305 Views
Registered: ‎10-01-2019

Re: Vivado Simulator 2019 runs forever for GTY transceiver example project

Thanks all for the reply. I got the simulation up and running. Actually the problem was with my set-up and I was overwirting the same project at multiple place and tool perhaps did not understand it properly. Now it is sorted and link is trained and link is up properly.

 

Regards

Hariharan K Srinivasan.