cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
fpgalearner
Voyager
Voyager
636 Views
Registered: ‎04-11-2016

xcvu080/xcvu065: Aurora 24g gty error

Jump to solution

Hi,

I am trying to configure aurora 64b66b for 24G serial connection using GTY Transceiver in xcvu080/xcvu065 (see attachement) but ended up with following error:

[IP_Flow 19-3477] Update of parameter 'PARAM_VALUE.TX_INT_DATA_WIDTH' failed for IP 'aurora_xcvu080_64b66b_GTY_24g_100m_4l/aurora_xcvu080_64b66b_GTY_24g_100m_2l_gt'. No 'DATA_WIDTHS_INTERNAL' device data found with qualifier(s): 64B66B 0
[IP_Flow 19-3477] Update of parameter 'PARAM_VALUE.RX_INT_DATA_WIDTH' failed for IP 'aurora_xcvu080_64b66b_GTY_24g_100m_4l/aurora_xcvu080_64b66b_GTY_24g_100m_2l_gt'. No 'DATA_WIDTHS_INTERNAL' device data found with qualifier(s): 64B66B 0
[IP_Flow 19-3461] Value '64' is out of the range for parameter 'User data width(TX_USER_DATA_WIDTH)' for IP 'aurora_xcvu080_64b66b_GTY_24g_100m_2l/aurora_xcvu080_64b66b_GTY_24g_100m_2l_gt' . Valid values are - 0
[IP_Flow 19-3461] Value '64' is out of the range for parameter 'User data width(RX_USER_DATA_WIDTH)' for IP 'aurora_xcvu080_64b66b_GTY_24g_100m_2l/aurora_xcvu080_64b66b_GTY_24g_100m_2l_gt' . Valid values are - 0

how to fix this?

 

24g_aurora.JPG
0 Kudos
1 Solution

Accepted Solutions
fpgalearner
Voyager
Voyager
539 Views
Registered: ‎04-11-2016
@jhua it has speed grade to do. I was using 1H speed grade instead of 1HV. The right one is for 24g is:
xcvu065-ffvc1517-1HV-e
xcvu080-ffvc1517-1HV-e

View solution in original post

3 Replies
jhua
Xilinx Employee
Xilinx Employee
572 Views
Registered: ‎06-01-2017

Hi @fpgalearner 

I was not able to reproduce the issue with a random xcvu080 I picked. Can you attach your xci and I can verify with the same GUI options?

Which Vivado version are you using? Have you verified with the latest 2019.2?

Thanks,
Jessica
------------------------------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
If starting with Versal take a look at our Versal Design Process Hub and our
Versal Blogs
------------------------------------------------------------------------------------------------
0 Kudos
fpgalearner
Voyager
Voyager
540 Views
Registered: ‎04-11-2016
@jhua it has speed grade to do. I was using 1H speed grade instead of 1HV. The right one is for 24g is:
xcvu065-ffvc1517-1HV-e
xcvu080-ffvc1517-1HV-e

View solution in original post

jhua
Xilinx Employee
Xilinx Employee
519 Views
Registered: ‎06-01-2017

Hi @fpgalearner 

I believe you have found an issue with the wizard GUI for -1H devices. Thanks for letting us know. I will follow up with development to resolve.

I was able to confirm in the standalone GT wizard that, for -1H devices, higher line rates are producing errors in the GUI:

image.png

Thanks,
Jessica
------------------------------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
If starting with Versal take a look at our Versal Design Process Hub and our
Versal Blogs
------------------------------------------------------------------------------------------------