cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
pgigliotti_usac
Explorer
Explorer
222 Views
Registered: ‎10-22-2020

Accessing lower level signals in Vivado simulator

Jump to solution

I have seen the literature, but cannot see the reason for the error. I am using 2020.1

I have the following code in my to level test bench, but I get a syntax error complaint near the "<"

 

constant FRAM_depth :integer := 2048;
type Fram_Mem_2048x8 is array (0 to (FRAM_depth -1)) of std_logic_vector(7 downto 0);
alias FRAM_memory_alias is <<signal Inst_VMUX_Top.INST_ADN4604.FRAM_Memory : Fram_Mem_2048x8>>;

 

I have also tried putting a dot in the path name, but still get the same error.

 

constant FRAM_depth :integer := 2048;
type Fram_Mem_2048x8 is array (0 to (FRAM_depth -1)) of std_logic_vector(7 downto 0);
alias FRAM_memory_alias is <<signal .Inst_VMUX_Top.INST_ADN4604.FRAM_Memory : Fram_Mem_2048x8>>;

 

As you can surmise, I am trying to access a lower level memory array.

0 Kudos
1 Solution

Accepted Solutions
pgigliotti_usac
Explorer
Explorer
178 Views
Registered: ‎10-22-2020

I ended up going into the file properties and selecting VHDL-2008 as the file type. (from UG 901) It seems there is not a way to set all files to VHDL-2008 and if doing so is a problem?

 

Setting up Vivado to use VHDL-2008

There are several ways to run VHDL-2008 files with Vivado.

You can go to the Source File Properties window, and set Type: VHDL 2008 from the drop-down of available file types. The Vivado tool then sets that the file type to VHDL-2008.

You can also set files to VHDL-2008 with the set_property command in the Tcl Console. The syntax is as follows:

set_property FILE_TYPE {VHDL 2008} [get_files .vhd]

Finally, in the Non-Project or Tcl flow, the command for reading in VHDL has VHDL-2008 is as follows:

read_vhdl -vhdl2008 .vhd

If you want to read in more than one file, you can either use multiple read_vhdl commands or multiple files with one command, as follows:

read_vhdl -vhdl2008 {a.vhd b.vhd c.vhd}

 

 

View solution in original post

0 Kudos
2 Replies
pgigliotti_usac
Explorer
Explorer
179 Views
Registered: ‎10-22-2020

I ended up going into the file properties and selecting VHDL-2008 as the file type. (from UG 901) It seems there is not a way to set all files to VHDL-2008 and if doing so is a problem?

 

Setting up Vivado to use VHDL-2008

There are several ways to run VHDL-2008 files with Vivado.

You can go to the Source File Properties window, and set Type: VHDL 2008 from the drop-down of available file types. The Vivado tool then sets that the file type to VHDL-2008.

You can also set files to VHDL-2008 with the set_property command in the Tcl Console. The syntax is as follows:

set_property FILE_TYPE {VHDL 2008} [get_files .vhd]

Finally, in the Non-Project or Tcl flow, the command for reading in VHDL has VHDL-2008 is as follows:

read_vhdl -vhdl2008 .vhd

If you want to read in more than one file, you can either use multiple read_vhdl commands or multiple files with one command, as follows:

read_vhdl -vhdl2008 {a.vhd b.vhd c.vhd}

 

 

View solution in original post

0 Kudos
richardhead
Scholar
Scholar
145 Views
Registered: ‎08-01-2012

To set all files to 2008, use

set_property FILE_TYPE {VHDL 2008} [get_files *.vhd]

0 Kudos