cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
matthiasl
Visitor
Visitor
232 Views
Registered: ‎05-18-2020

Block Windows 10 Updates during simulation

Hi all,

Another week, another Windows 10 update that crashes my work without my permission. I ran a longer simulation in Vivado 2020.2 and while I was away from my computer, Windows 10 "Professional" decided that now is a good point to restart my computer because THIS IS IMPORTANT NOW!

My question is: Is it possible in a setting or in a new version of Vivado to somehow tell Windows that it is busy doing something and the computer shall not be shut down? Like when in Windows 7 it asked you again before shutting down when there were unsaved documents.

This would be awesome!

Best regards,

Matthias

P.S.: Also looking for ways to permanently disable automatic updates - the Microsoft support couldn't help me and I'm aware it is possible to adjust times when working (oftentimes, my Vivado and Matlab simulations are running around the clock though) and postpone updates - however I forget to postpone them often as well...

0 Kudos
2 Replies
dpaul24
Scholar
Scholar
219 Views
Registered: ‎08-07-2014

@matthiasl ,

P.S.: Also looking for ways to permanently disable automatic updates - the Microsoft support couldn't help me and I'm aware it is possible to adjust times when working

Check the following setting in your PC marked in red. I run overnight sims and without my approval my PC never shuts down in order to install an update.

dpaul24_0-1618600471913.png

 

------------FPGA enthusiast------------
Consider giving "Kudos" if you like my answer. Please mark my post "Accept as solution" if my answer has solved your problem

matthiasl
Visitor
Visitor
203 Views
Registered: ‎05-18-2020

Thank you for the hint! It is already disabled in my case I tried to enable the option below though, like it is in your screenshot. Let's see if that helps.

0 Kudos