UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Explorer
Explorer
8,995 Views
Registered: ‎07-14-2011

Can't start up AXI4 BFM simulation, XPS 14.7

Jump to solution

I created some template peripheral which works in hardware. I want to simulate it now in BFM. The BFM simulation model creation tick was marked during the peripheral creation in wizard. And appropriate files were created as well.

 

I did compile the HDL libraries as well, without any errors.

 

However, when I start up the simulation, I got the following error:

 

# ** Error: (vsim-3033) C:/Xilinx/14.7/ISE_DS/EDK/hw/XilinxBFMinterface/pcores/cdn_axi4_lite_master_bfm_wrap_v2_01_b/hdl/verilog/cdn_axi4_lite_master_bfm_wrap.v(145): Instantiation of 'cdn_axi4_lite_master_bfm' failed. The design unit was not found.
# 
#         Region: /bfm_system_tb/dut/bfm_lite_processor/bfm_lite_processor
#         Searched libraries:
#             C:/Xilinx/14.7/ISE_DS/ISE/verilog/mti_se/10.2c/nt64/unisims_ver
#             C:/Xilinx/14.7/ISE_DS/ISE/verilog/mti_se/10.2c/nt64/edk/cdn_axi4_lite_master_bfm_wrap_v2_01_b
#             C:/Xilinx/14.7/ISE_DS/ISE/verilog/mti_se/10.2c/nt64/xilinxcorelib_ver
#             C:/Xilinx/14.7/ISE_DS/ISE/verilog/mti_se/10.2c/nt64/secureip
#             C:/Xilinx/14.7/ISE_DS/ISE/verilog/mti_se/10.2c/nt64/unisims_ver
#             C:/Xilinx/14.7/ISE_DS/ISE/verilog/mti_se/10.2c/nt64/unimacro_ver
#             C:/Xilinx/14.7/ISE_DS/ISE/verilog/mti_se/10.2c/nt64/edk/cdn_axi4_lite_master_bfm_wrap_v2_01_b

 

 

So it didn't find cdn_axi4_lite_master_bfm, and some others:

cdn_axi4_master_bfm

cdn_axi4_slave_bfm

 

The folders which it was looking in had those compiled libraries 

The folder: 

C:/Xilinx/14.7/ISE_DS/ISE/verilog/mti_se/10.2c/nt64/edk/cdn_axi4_lite_master_bfm_wrap_v2_01_b

Has typical files like, _info, _lib.qdb etc. (the result of complxlib process).

 

Why is the tool still saying that the design unit was not found? 

 

 

 

0 Kudos
1 Solution

Accepted Solutions
Explorer
Explorer
16,808 Views
Registered: ‎07-14-2011

Re: Can't start up AXI4 BFM simulation, XPS 14.7

Jump to solution

the direction was kinda right, thanks.

 

To be more precise, I had to do the following:

 

  • Open the “mti_secureip_cell.list.f” from the “C:\Xilinx\14.7\ISE_DS\ISE\secureip\mti” folder
  • Append this line: “-f $XILINX/secureip/mti/axi_bfm_mti/axi_bfm_cell.list.f”
  • In EDK, go to EDIT->Preferences, and compile libraries.

 

And then start process as usual again.

0 Kudos
4 Replies
Moderator
Moderator
8,990 Views
Registered: ‎04-17-2011

Re: Can't start up AXI4 BFM simulation, XPS 14.7

Jump to solution
From 14.5, there is a change in the simulation flow. Starting in 14.5, you will need to explicitly compile the BFM. Add the following line to your Modelsim .do file:

vlog -work secureip -f C:/Xilinx/14.7/ISE_DS/ISE/secureip/mti/axi_bfm_mti/axi_bfm_cell.list.f

There is no current plan to fix this in ISE design suite.
Regards,
Debraj
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
Explorer
Explorer
16,809 Views
Registered: ‎07-14-2011

Re: Can't start up AXI4 BFM simulation, XPS 14.7

Jump to solution

the direction was kinda right, thanks.

 

To be more precise, I had to do the following:

 

  • Open the “mti_secureip_cell.list.f” from the “C:\Xilinx\14.7\ISE_DS\ISE\secureip\mti” folder
  • Append this line: “-f $XILINX/secureip/mti/axi_bfm_mti/axi_bfm_cell.list.f”
  • In EDK, go to EDIT->Preferences, and compile libraries.

 

And then start process as usual again.

0 Kudos
8,732 Views
Registered: ‎07-15-2015

Re: Can't start up AXI4 BFM simulation, XPS 14.7

Jump to solution

Can you explain in details the procedure?

what does "Append this line: “-f $XILINX/secureip/mti/axi_bfm_mti/axi_bfm_cell.list.f” mean"?

0 Kudos
Highlighted
Moderator
Moderator
8,717 Views
Registered: ‎04-17-2011

Re: Can't start up AXI4 BFM simulation, XPS 14.7

Jump to solution
That should mean add the line -f $XILINX/secureip/mti/axi_bfm_mti/axi_bfm_cell.list.f
in the end of the file mti_secureip_cell.list.f which can be found in C:\Xilinx\14.7\ISE_DS\ISE\secureip\mti folder.
Regards,
Debraj
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
Tags (1)
0 Kudos