UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
13,442 Views
Registered: ‎12-17-2010

ERROR:Compxlib:368 - Compxlib does not support mti_se version 6.3b or prior releases.

Jump to solution

I have been using ISE 12.3 (Linux 64) and simulation using isim.  All working fine.  But I have just installed Modelsim SE 10.0 and have been having difficutly getting ISE to use modelsim.  I modified the Design Properties to select the Modelsim-SE Verilog simulator and ISE seems to have picked up the correct path to my modelsim installation directory.  However, when I tried to simulate my test bench (from ISE), the ISE Project Navigator produced a warning window: "WARNING: Failed to get the pre-compiled simulation library information..."  After some reading of the manual I concluded that I need to precompile the simulation libraries using the compxlib command.  Doing so, I get this error:

 

ERROR:Compxlib:368 - Compxlib does not support mti_se version 6.3b or prior releases. Parsing through the path setting on your system we have identified that you are using mti_se '2010.12'.
Please contact Mentor Graphics to upgrade to a supported simulator version. If the path setting is incorrect, please ensure that you are pointing to the latest version and re-invoke compxlib.
The list of supported simulator versions are listed in the Simulation Chapter of the Synthesis and Simulation Design Guide on http://www.xilinx.com.
Simulator 'mti_se' is ignored.

 

I have the latest version of Modelsim.  Is this a bug?  If not, can anyone hint as to where I go from here?

 

Cheers,

Nathan

 

0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
16,241 Views
Registered: ‎08-15-2007

Re: ERROR:Compxlib:368 - Compxlib does not support mti_se version 6.3b or prior releases.

Jump to solution

All,

 

Please see Xilinx Answer 38609:  http://www.xilinx.com/support/answers/38609.htm 

 

This is a known issue and will be addressed in ISE Design Suite 13.1, due out Spring.

 

For 12.3 and 12.4, use the latest modelSim 6.6 update.

 

 

Eddie

View solution in original post

0 Kudos
12 Replies
Newbie marvias
Newbie
13,431 Views
Registered: ‎12-18-2010

Re: ERROR:Compxlib:368 - Compxlib does not support mti_se version 6.3b or prior releases.

Jump to solution

looks like you need to downgrade to  modelsim 6.x, had same problem and downgrade worked :)

0 Kudos
Xilinx Employee
Xilinx Employee
13,403 Views
Registered: ‎07-16-2008

Re: ERROR:Compxlib:368 - Compxlib does not support mti_se version 6.3b or prior releases.

Jump to solution

What command options did you use when running compxlib?

-s and -p could be used to specify simulator and its executable path.

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Adventurer
Adventurer
13,388 Views
Registered: ‎12-20-2010

Re: ERROR:Compxlib:368 - Compxlib does not support mti_se version 6.3b or prior releases.

Jump to solution

I have the same problem.  Here's the options I used:

 

compxlib -s mti_pe -p "C:\Program Files\Modelsim_PE_10.0\win32pe" -l all -arch spartan6 -arch virtex5 -arch virtex6 -lib all -w

 

 

ERROR:Compxlib:368 - Compxlib does not support mti_pe version 6.3b or prior releases. Parsing through the path setting on your system we have identified that you are using mti_pe '2010.12'.
Please contact Mentor Graphics to upgrade to a supported simulator version. If the path setting is incorrect, please ensure that you are pointing to the latest version and re-invoke compxlib.
The list of supported simulator versions are listed in the Simulation Chapter of the Synthesis and Simulation Design Guide on http://www.xilinx.com.
Simulator 'mti_pe' is ignored.


0 Kudos
Highlighted
Adventurer
Adventurer
13,378 Views
Registered: ‎08-01-2007

Re: ERROR:Compxlib:368 - Compxlib does not support mti_se version 6.3b or prior releases.

Jump to solution

It looks like ModelSim 10.0 is too new for Compxlib to recognize as a successor to 6.3b.  Your best bet is to downgrade one version down and install 6.6d instead.  The archive is located at http://model.com/content/modelsim-pe-simulation-and-debug

0 Kudos
Xilinx Employee
Xilinx Employee
16,242 Views
Registered: ‎08-15-2007

Re: ERROR:Compxlib:368 - Compxlib does not support mti_se version 6.3b or prior releases.

Jump to solution

All,

 

Please see Xilinx Answer 38609:  http://www.xilinx.com/support/answers/38609.htm 

 

This is a known issue and will be addressed in ISE Design Suite 13.1, due out Spring.

 

For 12.3 and 12.4, use the latest modelSim 6.6 update.

 

 

Eddie

View solution in original post

0 Kudos
Xilinx Employee
Xilinx Employee
13,340 Views
Registered: ‎09-14-2007

Re: ERROR:Compxlib:368 - Compxlib does not support mti_se version 6.3b or prior releases.

Jump to solution

Hi,

 

Please open a case with technical support if you cannot wait. A tactical patch could be made avaialble if needed.

 

Thanks

Duth

 

0 Kudos
13,316 Views
Registered: ‎12-17-2010

Re: ERROR:Compxlib:368 - Compxlib does not support mti_se version 6.3b or prior releases.

Jump to solution

Thanks for your help everyone.

 

I chose to revert back to modelsim 6.6d.  This works fine and will do until the new version of ISE is available.

 

Cheers,

Nathan

 

0 Kudos
Visitor scottramsey
Visitor
12,440 Views
Registered: ‎11-03-2009

Re: ERROR:Compxlib:368 - Compxlib does not support mti_se version 6.3b or prior releases.

Jump to solution

Was a patch ever made to fix this issue for ISE 12.3? 

 

I have just upgraded to Modelsim 10.0a and get this error with 12.3. 

0 Kudos
Xilinx Employee
Xilinx Employee
12,397 Views
Registered: ‎09-14-2007

Re: ERROR:Compxlib:368 - Compxlib does not support mti_se version 6.3b or prior releases.

Jump to solution

Hi,

 

There should have been one for 12.3 or 12.4, please open a case to get access to it.

 

Is there a reason why you cant upgrade to 13.1 of ISE? The issue does not exist in 13.1..


Thanks

Duth

 

0 Kudos
Visitor scottramsey
Visitor
5,354 Views
Registered: ‎11-03-2009

Re: ERROR:Compxlib:368 - Compxlib does not support mti_se version 6.3b or prior releases.

Jump to solution

Thanks, but for now I have just reverted back to Modelsim 6.6d and it worked fine. 

0 Kudos
Visitor trevor3
Visitor
4,893 Views
Registered: ‎11-07-2007

Re: ERROR:Compxlib:368 - Compxlib does not support mti_se version 6.3b or prior releases.

Jump to solution

That is not true about not being able to use modelsim PE 10 with ISE 12.4. I am currently using modelsim PE 10 from ISE 12.4 FYi

Tags (1)
0 Kudos
Newbie bradc2012
Newbie
4,877 Views
Registered: ‎04-28-2012

Re: ERROR:Compxlib:368 - Compxlib does not support mti_se version 6.3b or prior releases.

Jump to solution

Hello, just wanted to say thank you for that solution!!!

0 Kudos