cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
9,000 Views
Registered: ‎12-24-2014

Elapsed simulation time is much higher than CPU time

Hello,

 

I'm trying to speed up my simulation, I'm using -mt flags and all, and I've payed attention, that after simulation ends, the elapsed time (the real time of simulation run) is much higher than CPU time, although I see CPU is 100% utilized during the run. 

 

I'm using linux64, 16 cores, 64GB memory.

 

Am I missing something? What could be the reason for that?

 

Example1:

run: Time (s): cpu = 00:12:36 ; elapsed = 01:09:35 . Memory (MB): peak = 5149.230 ; gain = 309.867

 

Example2:

run: Time (s): cpu = 00:12:06 ; elapsed = 01:03:07 . Memory (MB): peak = 6166.566 ; gain = 0.000

 

Example3:

run: Time (s): cpu = 00:04:23 ; elapsed = 00:38:57 . Memory (MB): peak = 4945.793 ; gain = 117.945

0 Kudos
6 Replies
Highlighted
Observer
Observer
2,835 Views
Registered: ‎12-22-2014

Re: Elapsed simulation time is much higher than CPU time

I am facing the same situation

 

run: Time (s): cpu = 00:49:36 ; elapsed = 15:11:46 . Memory (MB): peak = 8125.973 ; gain = 379.031 ; free physical = 7436 ; free virtual = 31083

 

Any Idea of the possible cause for this low performance?

I am running an 8 cores system, with 32GB of mem

Not all the memory is being used, and 

I tried forcing "-mt" option in simulation options, but it has no effect, and only one processor is working the other are iddle...

 

%Cpu0 : 2.3 usuario, 0.7 sist, 0.0 adecuado, 96.7 inact, 0.3 en espera, 0.0 hardw int, 0.0 softw int, 0.0 robar tiempo
%Cpu1 : 2.6 usuario, 1.0 sist, 0.0 adecuado, 95.7 inact, 0.7 en espera, 0.0 hardw int, 0.0 softw int, 0.0 robar tiempo
%Cpu2 : 4.6 usuario, 0.7 sist, 0.0 adecuado, 94.7 inact, 0.0 en espera, 0.0 hardw int, 0.0 softw int, 0.0 robar tiempo
%Cpu3 : 0.0 usuario, 0.0 sist, 0.0 adecuado,100.0 inact, 0.0 en espera, 0.0 hardw int, 0.0 softw int, 0.0 robar tiempo
%Cpu4 : 1.6 usuario, 3.2 sist, 0.0 adecuado, 94.5 inact, 0.6 en espera, 0.0 hardw int, 0.0 softw int, 0.0 robar tiempo
%Cpu5 : 1.3 usuario, 0.3 sist, 0.0 adecuado, 98.3 inact, 0.0 en espera, 0.0 hardw int, 0.0 softw int, 0.0 robar tiempo
%Cpu6 : 2.6 usuario, 0.7 sist, 0.0 adecuado, 96.7 inact, 0.0 en espera, 0.0 hardw int, 0.0 softw int, 0.0 robar tiempo
%Cpu7 :100.0 usuario, 0.0 sist, 0.0 adecuado, 0.0 inact, 0.0 en espera, 0.0 hardw int, 0.0 softw int, 0.0 robar tiempo
KiB Mem : 32889376 total, 7172868 free, 8039600 used, 17676908 buff/cache

0 Kudos
Highlighted
Moderator
Moderator
2,829 Views
Registered: ‎09-15-2016

Re: Elapsed simulation time is much higher than CPU time

Hi @jomarm10

 

Are you facing this issue specific to simulation or other Vivado applications as well?

Check this AR https://www.xilinx.com/support/answers/56840.html

 

As per me, one reason of  the possible  elapsed time going very high could be that you have network installation and you are accessing  the files from your local disk. I have seen this issue in Vivado with Windows network installation.

 

Regards

Rohit

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

 

 

 

 

Regards
Rohit
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

0 Kudos
Highlighted
Observer
Observer
2,826 Views
Registered: ‎12-22-2014

Re: Elapsed simulation time is much higher than CPU time

Hi,

This low performance is only for the simulation.

All files are local, only Vivado license server is placed in a remote server, 

I am running vivado 2016.2 under an Ubuntu 16.04 LTS

0 Kudos
Highlighted
Moderator
Moderator
2,814 Views
Registered: ‎09-15-2016

Re: Elapsed simulation time is much higher than CPU time

Hi @jomarm10

 

Ubuntu 16.04 LTS is not a supported OS for Vivado 2016.2 which you are using. Such undeterministic results are seen when unsupported OS is used as you mention that the issue is with simulation only.  Can you please use supported OS and see if you face same issue. Please refer the below link, page 8  for information regarding supported OS for 2016.2:

https://www.xilinx.com/support/documentation/sw_manuals/xilinx2016_2/ug973-vivado-release-notes-install-license.pdf

 

Parallely you can also try with the following and see if it helps:

1) Try changing -mt option to value other than auto.

2) Also to speed up simulation run time,  use Fast Model by Enabling the fast sim models in Sim properties. Please refer the below link,page 22 for information  on this.

https://www.xilinx.com/support/documentation/sw_manuals/xilinx2016_2/ug900-vivado-logic-simulation.pdf

 

Hope the shared information will be useful. Please note that use of supported OS is must for the Vivado verison you are using as per Xilinx.

 

Regards

Rohit

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

 

 

 

Regards
Rohit
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

Highlighted
Observer
Observer
2,802 Views
Registered: ‎12-22-2014

Re: Elapsed simulation time is much higher than CPU time

Hi @thakurr

Ok, I see that ubuntu 14.03 is the one that is supported. I will check if we can go back to that version.

 

In the meantime,

I already tried both tips, with dispair results.

Forcing "-mt" to a fixed value has no effect .

Enabling FASTSIM works,

  set_property unifast true [current_fileset sim_1]

improving simulation elapsed time between a 15% to 20%.

 

Thank you.

jose

Regards,

Jose

0 Kudos
Highlighted
Observer
Observer
2,789 Views
Registered: ‎12-22-2014

Re: Elapsed simulation time is much higher than CPU time

I installed Vivado 2016.4, that supports Ubuntu 16.04 LTS
https://www.xilinx.com/support/documentation/sw_manuals/xilinx2016_4/ug973-vivado-release-notes-install-license.pdf

 

but the numbers are very similar (a little bit worse)

run: Time (s): cpu = 00:00:21 ; elapsed = 00:06:02 . Memory (MB): peak = 6986.918 ; gain = 0.000 ; free physical = 17318 ; free virtual = 28580

 

0 Kudos