cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
1,339 Views
Registered: ‎02-07-2018

Export Simulation Warning : IP component xml file not found

Hi,

 

I have used AXI4 smart-connect in my block design, everything works fine i.e; like Validation, Generate Block design, Create HDL wrapper, adding test bench. But when i choose Export Simulation i get a warning which says

 

WARNING : [SIM-utils-52] IP Component XML file dose not exist.

 

And for the file to which this warning was meant to be cannot be found when i try to simulate the design.

 

Can anyone help me out with this.

 

Please find the attachment below.

xml.PNG
0 Kudos
2 Replies
Highlighted
Moderator
Moderator
1,305 Views
Registered: ‎09-15-2016

Hi @praveen_mulimani,

 

The  IP .xml file is not present during export simulation in .srcs/sources_1/bd/design_1/ip/<axismartconnect>/<name>.xml and hence this warning. This file (with .xci) should be created when you add the IP in BD for a project and save (as this IP can be used in IPI flow only). Usually .xml is present with this flow and I am not sure why not in this case.

If you are just trying out the IP, then generating output products should also run export_simulation within the scripts in .ip_user_files/sim_scripts to compare. Also for working in design with IP, to use export_simulation make sure you have compiled the libraries.

 

Regards,
Prathik
-----------------------------------------------------------------------------------------------
Please mark the appropriate post as an answer "Accept as solution" in case it helps to resolve your query.
Give Kudos to a post which you think is helpful and reply oriented.
-----------------------------------------------------------------------------------------------

0 Kudos
1,298 Views
Registered: ‎02-07-2018

Hi prathikm

 

Thanks for the reply, this issue is resolved by selecting "Out of context per Block Design " option while generating output products. Before i selected "Out of context per IP" option and hence i was getting that warning .

0 Kudos