cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
5,959 Views
Registered: ‎06-12-2012

FATAL_ERROR:simulator: compilerUtils.cpp:672:1.50

Jump to solution

when i do a simulation, the isim does not get out, and the console table list the following message:

           FATAL_ERROR:simulator: compilerUtils.cpp:672:1.50 - Directory pointed to by XILINX environment variable does not have gcc installed.

          to this problem, i have try many methods.

          gcc had already been  installed in my pc.

          win xp has been re-installed.

          other ise project has been try.

          but, the problem is always there.

          my ise version is 13.4, and i try to use 13.1. at the beginning of the one, two,three simulation, the isim runs ok, but then the same fatal error out, and cannot similate again.help me!

sdh switch pcie qq community: 292877592
Tags (1)
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Xilinx Employee
Xilinx Employee
7,670 Views
Registered: ‎07-16-2008

Re: FATAL_ERROR:simulator: compilerUtils.cpp:672:1.50

Jump to solution

On Windows, the GCC should be installed at $XILINX\\gnu\MinGW. Please make sure the installation is complete.

 

A previous known issue is addressed in the following answer. Please see if you've set these environment variables.

www.xilinx.com/support/answers/33845.htm

 

If the above doesn't help, specify "-v 1" in Simulation properties > Other Compiler Options field to get a verbose fuse.log. See if it can help debug the failure.

 

 

 

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

0 Kudos
5 Replies
Highlighted
Xilinx Employee
Xilinx Employee
7,671 Views
Registered: ‎07-16-2008

Re: FATAL_ERROR:simulator: compilerUtils.cpp:672:1.50

Jump to solution

On Windows, the GCC should be installed at $XILINX\\gnu\MinGW. Please make sure the installation is complete.

 

A previous known issue is addressed in the following answer. Please see if you've set these environment variables.

www.xilinx.com/support/answers/33845.htm

 

If the above doesn't help, specify "-v 1" in Simulation properties > Other Compiler Options field to get a verbose fuse.log. See if it can help debug the failure.

 

 

 

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

0 Kudos
Highlighted
Visitor
Visitor
5,943 Views
Registered: ‎06-12-2012

Re: FATAL_ERROR:simulator: compilerUtils.cpp:672:1.50

Jump to solution
first, the installation directory of xilinx 13.4 is below:
C:\Xilinx\13.4\ISE_DS\....
below the ISE_DS folder, there are many other folders, like xinstall, common, EDK, ISE, PlanAhead,and so on.
so, where should i install the gcc.
the gcc version that i download is tdm-gcc-4.6.1
second, the environment variable is not set in my system
last but most important, thank you very much
sdh switch pcie qq community: 292877592
0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
5,940 Views
Registered: ‎07-16-2008

Re: FATAL_ERROR:simulator: compilerUtils.cpp:672:1.50

Jump to solution

$XILINX points to C:\Xilinx\13.4\ISE_DS\ISE.

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Highlighted
Visitor
Visitor
5,938 Views
Registered: ‎06-12-2012

Re: FATAL_ERROR:simulator: compilerUtils.cpp:672:1.50

Jump to solution
exactly unbelievable ! graces! let's have a hug!
i have questioned the xilinx tech support.
they give many methods.
but the installation directory of gcc is not given by them, they only ask me whether i installed gcc!
so i think you are experts.
this problem take me too much time!
ok, now go on me design!
my friend, you, enjoy time!
sdh switch pcie qq community: 292877592
0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
5,935 Views
Registered: ‎07-16-2008

Re: FATAL_ERROR:simulator: compilerUtils.cpp:672:1.50

Jump to solution

Glad to hear that you've solved the problem. I'll mark this thread as solved.

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos