cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
1,503 Views
Registered: ‎07-05-2016

Generate secureip library for Questasim

Jump to solution

I am using ISE 14.7, trying to generate the secureip library for Questasim.  When I run compxlib with this command,

compxlib -s questa -l vhdl -p C:\Apps\questasim107b\nt64\ -w -lib unisim  

 

It doesn't create the library and I get many errors in the compxlib.log file like this:

 

BEGIN_COMPILATION_MESSAGES(questasim:vhdl:unisim)
QuestaSim-64 vmap 10.7b Lib Mapping Utility 2018.06 Jun 8 2018
vmap unisim C:\apps\Xilinx\14.7\ISE_DS\ISE\vhdl\questasim\10.7b\nt64/unisim
Modifying modelsim.ini

** Warning: (vcom-159) Mode option -32 is not supported in this context and will be ignored.
QuestaSim-64 vcom 10.7b Compiler 2018.06 Jun 8 2018
** Error (suppressible): (vcom-12110) All optimizations are disabled because the -novopt option is in effect. This will cause your simulation to run very slowly. If you are using this switch to preserve visibility for Debug or PLI features, please see the User's Manual section on Preserving Object Visibility with vopt. -novopt option is now deprecated and will be removed in future releases.
Errors: 1, Warnings: 1

 

I get the same errors when I run "Compile HDL Simulation Libraries" from the Process menu.

 

What am I missing?

 

thanks,

John

 

 

 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Moderator
Moderator
1,493 Views
Registered: ‎11-04-2010
Could you try to compile the simlib in QuestaSim 10.1b or 10.5?
-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

0 Kudos
3 Replies
Highlighted
Moderator
Moderator
1,494 Views
Registered: ‎11-04-2010
Could you try to compile the simlib in QuestaSim 10.1b or 10.5?
-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
1,435 Views
Registered: ‎07-16-2008

As Hong pointed out, it's recommended that you run in Questasim 10.1b, which is compatbile with ISE 14.7.

Please refer to ISE Release Notes, pg9, Table 2-2.

http://www.xilinx.com/support/documentation/sw_manuals/xilinx14_7/irn.pdf

 

The compilation script generated by compxlib has option -novopt in vcom/vlog commands. This option is deprecated in 10.7, and hence the error.

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Highlighted
Visitor
Visitor
1,422 Views
Registered: ‎07-05-2016
I copied the library that was previously compiled with Questa 10.2. That worked for me. Thank you!
0 Kudos