cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
alangford
Participant
Participant
921 Views
Registered: ‎06-15-2017

ISim - F3 Run All - Doesn't Work

Using Vivido 2017.2 with ISim on Windows 10 ...

 

The F3 "Run All" shortcut doesn't work on my Vivido 2017.2 instal on Windows 10 ... simple as that ... yet another bug with this tool

 

Instead it advances the cursor along the line 

0 Kudos
2 Replies
balkris
Xilinx Employee
Xilinx Employee
900 Views
Registered: ‎08-01-2008

i will check on this . Can you please refer page 147 section configuring short cut key. It may help you

https://www.xilinx.com/support/documentation/sw_manuals/xilinx2017_4/ug893-vivado-ide.pdf

Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
alangford
Participant
Participant
864 Views
Registered: ‎06-15-2017

I should expand ... Im specifically seeing this issue when "debugging" a simulation. 

 

When the focus is the waveform window, the F3 shortcut key does as it should, it continues the simulation

 

However, when the focus is the text editor where I've hit a breakpoint, pressing F3 doesnt do anything, whilst pressing the "run-all" triangle button does as it should, it continues the simulation.

 

I have a number of breakpoints in my testbench file. I'd like to press F3 to run from one breakpoint to the next. Instead, I have to press the run-all button within the GUI

 

Interestingly, the shortcut for "step" = F8 does work 

 

I didnt see anything in ug893 that would help me

 

 

 

0 Kudos