cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
behzad34
Visitor
Visitor
8,078 Views
Registered: ‎08-28-2013

ISim elaborating problem due to having huge RAMs

Hello

 

I have a problem with isim elaborating process that I wonder if anybody can help.

In my VHDL project, I have 2 huge RAMs with the lenght of 300,000 of 32 bit data (using block memory generator, true dual port RAM). When I include the RAMs and Simulate Behavioral Model, the isim window is opened up but mentions "elaborating ...". This elaborating takes half a day and in the process my computer memory usage becomes full usage (8GB). After that, I cannot still simulate my design by pressing the run botton.

 

I would really much appreciate if anybody can help me.

 

Behzad

 

0 Kudos
3 Replies
gszakacs
Instructor
Instructor
8,059 Views
Registered: ‎08-14-2007

When you generated the memory core, did you select behavioral or structural model?  I would expect the behavioral model to simulate much faster.

-- Gabor
0 Kudos
behzad34
Visitor
Visitor
8,050 Views
Registered: ‎08-28-2013

Thanks for your response.

 

So, how should I select the options of the attached photo to simulate in behavioral mode? Do I need to select "none" in the structural simulation model and then select "disable collision warnings"?

 

thanks a lot 

Untitled.jpg
0 Kudos
gszakacs
Instructor
Instructor
8,046 Views
Registered: ‎08-14-2007

The settings you show do not control which model is generated.  You need to do that in the CoreGen project settings.  If you got here from the GUI using "Project --> New Source..." you bypass that screen and should end up with Behavioral models.  In any case the fastest simulation would be with no collision warnings, although I don't know how much difference it would make.  I generally leave these settings at their defaults.  If you want to be sure you are generating behavioral models, you should select an existing core in the design panel of the ISE GUI and select the process "Manage Cores."  That brings you to the main Core Generator screen where you can change the project options.  Make sure the generation setting is for Behavioral.  Then if necessary regenerate the core under current project settings.

-- Gabor
Behavioral.PNG
0 Kudos