UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor dmatkin
Visitor
176 Views
Registered: ‎01-20-2019

Invalid Top Level Simulation Setting Compile order (Failing to resolve RTL modules)

Jump to solution

Hello, I ran into a bit of an issue while I was working on a testbench. I saved part way through while the module was invalid. It gave me the warning that the top module was invalid. Knowing that I would be fixing this later I selected to leave the top module as invalid. This without my knowing changed the hierarchy settings so I had Automatic Update but manual compile order. 

This was a problem cause I have a lot of RTL files in my design and with manual compile, they don't resolve. However, as I didn't know this change had been made it never occurred to me. The fact that module references don't work with manual compile is a warning not an error and therefore It took me quite some time to notice that that was where the problem was coming from. 

This was simply fixed once noticed by changing the compile order back to fully automatic (right click in the sources window and look under hierarchy update). Maybe they'll change it so in cases where it will not resolve an RTL file it actually throws an error if they're included in the block design, but till then I just wanted to post so the solution shows up in google :P. 

 

0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
141 Views
Registered: ‎05-31-2017

Re: Invalid Top Level Simulation Setting Compile order (Failing to resolve RTL modules)

Jump to solution

Hi @dmatkin ,

Thanks for sharing your Issue and Solution with us.

Generally, if the hierarchy update is set to Automatic update and Manual compile order then, it completely depends on the user to make sure that you have provided the correct compile order in the Compile Order window. Also, you need to make sure that all the sub modules are compiled before the top module in which you have instantiated the submodules. After changing the hierarchy update setting to Automatic compile order the tool will take care of the compile order, compiles all the files correctly due to which you see no issues.

1 Reply
Moderator
Moderator
142 Views
Registered: ‎05-31-2017

Re: Invalid Top Level Simulation Setting Compile order (Failing to resolve RTL modules)

Jump to solution

Hi @dmatkin ,

Thanks for sharing your Issue and Solution with us.

Generally, if the hierarchy update is set to Automatic update and Manual compile order then, it completely depends on the user to make sure that you have provided the correct compile order in the Compile Order window. Also, you need to make sure that all the sub modules are compiled before the top module in which you have instantiated the submodules. After changing the hierarchy update setting to Automatic compile order the tool will take care of the compile order, compiles all the files correctly due to which you see no issues.