cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Contributor
Contributor
9,770 Views
Registered: ‎03-05-2014

Java exceptions running simulation in vivado 2014.3

Jump to solution

Hi.

I am trying to simulate a design using vivado, but when I launch simulation I get some java exceptions.
java.lang.reflect.InvocationTargetException and java.lang.NullPointerException

The project I have tested is the one from UG871, chapter 9 lab 1 (RTL verification). I've attached the project as well as the log/debug files I get from the execution.

I think that it can be related to an error I also get when trying to open a simulation trace [1]

I am using vivado 2014.3 on an ubuntu 14.04 machine.

[1] http://forums.xilinx.com/t5/Simulation-and-Verification/Error-opening-trace-files-in-vivado-2014-3/td-p/552367

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Contributor
Contributor
17,106 Views
Registered: ‎03-05-2014

I finally got Vivado reinstalled in that machine and now everything works just fine :)

View solution in original post

0 Kudos
4 Replies
Highlighted
Xilinx Employee
Xilinx Employee
9,759 Views
Registered: ‎04-16-2012

Hello @afilgueras 

 

I am able to succesfully run the simulation in Windows 7 64-bit with the attached project.

Can you try running the simulation by invoking vivado in 32-bit mode?

 

Thanks,

Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
Highlighted
Contributor
Contributor
9,752 Views
Registered: ‎03-05-2014

I get an error when trying to run in 32bit moce (vivado -m32)

 

application-specific initialization failed: couldn't load file "librdi_commontasks.so": libncurses.so.5: cannot open shared object file: No such file or directory

 

:(

0 Kudos
Highlighted
Contributor
Contributor
9,722 Views
Registered: ‎03-05-2014

I managed to install vivado in my local machine and it works perfectly.

 

I checked the installation and I noticed that a file named simulation.jar was missing. :(

I think this is causing the java ClassNotFoundException leading to other errors (NullpointerException, etc.).

 

I will contact the sysamins so they can fix this for me. At this point I think this also explains errors while trying to visualize traces in [1] since this seems to be a GUI problem.

 

[1] http://forums.xilinx.com/t5/Simulation-and-Verification/Error-opening-trace-files-in-vivado-2014-3/td-p/552367

0 Kudos
Highlighted
Contributor
Contributor
17,107 Views
Registered: ‎03-05-2014

I finally got Vivado reinstalled in that machine and now everything works just fine :)

View solution in original post

0 Kudos