UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor avigailr
Visitor
341 Views
Registered: ‎01-18-2018

LD_LIBRARY_PATH for Vivado 2017.1

Hi,

 

We're using the cmodel provided by xfft_v9_0 in our verification env (using DPI).

The cmodel DLL is "libIp_xfft_v9_0_bitacc_cmodel.so", and it uses "libgmp.so.11" and "libgmpxx.so.4".

In order to use the cmodel DLL, we need to set the LD_LIBRARY_PATH env variable (following PG109, page 69).

 

We tried to follow AR #60154, setting the LD_LIBRARY_PATH in:

"/opt/Xilinx/Vivado/2017.1/.settings64-Vivado.sh"

to:

"$XILINX_VIVADO/ids_lite/ISE/lib/lin64:$LD_LIBRARY_PATH"

but then other processes (like gvim) don't work.

 

This issue was addressed in AR #66998, suggesting to remove LD_LIBRARY_PATH all together, but I think we must use it in order to get the cmodel DLL to work..

 

Is there any way to set LD_LIBRARY_PATH just for Vivado (using Vivado's tcl scripts), or any other work around?

 

Thanks!!!

 

Here are some links we browsed:

 

From PG109 , page 69:

 

 

Installation
On Linux, ensure that the directory in which the files 
libIp_xfft_v9_0_bitacc_cmodel.so, libgmp.so.11 and libgmpxx.so.4
 are 
located is in your $LD_LIBRARY_PATH environment variable.

 

 

https://www.xilinx.com/support/documentation/ip_documentation/xfft/v9_0/pg109-xfft.pdf

 

AR #60154:

https://www.xilinx.com/support/answers/60154.html

 

AR #66998:

https://www.xilinx.com/support/answers/66998.html

 

Similar issue from VIM forum:

http://vim.1045645.n5.nabble.com/new-tool-lib-conflict-with-gvim-lib-td5730308.html

0 Kudos