Showing results for 
Show  only  | Search instead for 
Did you mean: 
Registered: ‎06-25-2014

Long simulation times when using XFFT IP - XSIM - 2019.2

Since implementing the Xilinx XFFT into my design my behavioral simulations have increased from 1 minute to 5 mins even though the stimulus to the DUT is the same at the moment. Strangely the post-synthesis and post-implementation versions of the same tests have stayed at 1 min.

I change test numbers by changing through tcl a testbench generic using --generic_top with the xelab command and this seems to require xelab to recreate the entire design because it 'sees' a change in it even though the only change is to the top level testbench. This xelab run appears to be taking up the majority of the simulation time. With the actual xsim run taking no time at all.

I have tried lots of things (xelab optimizations, debug_off, pre-compiled libs, etc) but nothing appears to effect the simulation time drastically.

I run a lot of tests for regression testing and will be running even more as I develop the firmware further. So this increased will have quite an effect on the development.

Any ideas?

0 Kudos
0 Replies