UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser: Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Reply

Need help with ISim Time resolution setting

Explorer
Posts: 109
Registered: ‎11-07-2008

Need help with ISim Time resolution setting

Hello All,

 

I am trying to set the timing resolution of the ISim, currently it is at 1ps and I wish to change it to 1ns.

After reading a thread in this group i used the following comman in the simulation properties other compiler options field:

 

"-timescale 1ps/1ns  -override_timeprecision"  (without quotes, Right Click "Simulate Behavioral Model" --> Properties --> Advanced)

 

 

but I get the following error:

 

ERROR:Simulator:834 - "N:/L.57/rtf/verilog/src/unisims/ODDR2.v" Line 24. The time unit (1ps) for the module (ODDR2(INIT=1'b1)) is less than the time precision (1ns).

 

I looked it over google and also on the asnwers link on Xilinx but couldnt find any reference.

 

Any bit of help is highly appreciated. Thanks in advance!!

 

Shax

Xilinx Employee
Xilinx Employee
Posts: 272
Registered: ‎08-15-2007

Re: Need help with ISim Time resolution setting

Hello Shax,


Refer to Xilinx Answer 22498.  Some Xilinx primitive models (such as the ODDR2 model in question) require a simulator precision of 1 ps.

Eddie
Visitor
Posts: 1
Registered: ‎10-05-2009

Re: Need help with ISim Time resolution setting

It looks like Shax's simulator error is due to the reversal of the 1ps and 1ns precision and unit args.

 

His example:

"-timescale 1ps/1ns  -override_timeprecision"

 

Correct usage for 1ns unit, 1ps precision:

"-timescale 1ns/1ps  -override_timeprecision"

 

What still isn't clear to me is whether "timing resolution" is referring to time precision or the time unit?