cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Explorer
Explorer
981 Views
Registered: ‎01-15-2019

[Questa] (vopt-1127) Error message - "VHDL file ... not selected for default binding because it is out of date"

Hi All,

I've received the following error message while compiling the Vivado Project with Questa:

** Error (suppressible): 
C:\Xilinx\Vivado\2018.3\data\ip\xilinx\c_counter_binary_v12_0\hdl\c_counter_binary_v12_0_vh_rfs.vhd(64):
(vopt-1127) Entity c_counter_binary_v12_0_12.c_counter_binary_v12_0_12_viv
was not selected for default binding because it is out of date
relative to dependency xbip_utils_v3_0_9.xbip_utils_v3_0_9_pkg, xbip_counter_v3_0_5.xbip_counter_v3_0_5_viv_comp,
c_counter_binary_v12_0_12.c_counter_binary_v12_0_12_pkg, xbip_counter_v3_0_5.xbip_counter_v3_0_5_pkg.

It seems the problem is with the precompiled VHDL libs...

How to solve?

Thank you!

 

 

0 Kudos
7 Replies
Highlighted
Xilinx Employee
Xilinx Employee
957 Views
Registered: ‎07-16-2008

回复: [Questa] (vopt-1127) Error message - "VHDL file ... not selected for default binding because it is out of date"

Yes, the error seems to indicate the pre-compiled library for the entity unit is out-of-date and needs to be re-compiled.

Have you successfully compiled 2018.3 simulation libraries targetting the current version of Questasim?

Does the modelsim.ini in use include the desired library mappings?

 

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
Highlighted
Explorer
Explorer
940 Views
Registered: ‎01-15-2019

回复: [Questa] (vopt-1127) Error message - "VHDL file ... not selected for default binding because it is out of date"

 

Yes, I recompiled ALL the Xilinx simulation libraries for Questa (Vivado -> Tools -> Compile Simulation Libraries -> Compile All Libraries for All Languagesa and All Families), but this did not help ...

As for the Questa, I have several versions installed on my PC - Questa 10.6d, Questa 10.7 ...

How does Questa knows what Xilinx libraries look for and there location? 

Where the questa_lib should be mapped to? Here is how it appears in the Questa Project:

1.jpg

As you can see, it appears as "empty"... Should it be so? Actually the "C:/Projects/xgs/ex2sim/2019-04-30/questa/" is the directory where the Vivado Project Simulation for Questa was exported to (Vivado -> Export for Simulation ...)

"Does the modelsim.ini in use include the desired library mappings?" - yes, the libs are mapped in the modelsim.ini ...


1.jpg

Thank you

0 Kudos
Highlighted
Explorer
Explorer
921 Views
Registered: ‎01-15-2019

回复: [Questa] (vopt-1127) Error message - "VHDL file ... not selected for default binding because it is out of date"

 

Is there any help? Idea?

How to solve this issue (default bounding and out-of-date entity)?

 

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
908 Views
Registered: ‎07-16-2008

回复: [Questa] (vopt-1127) Error message - "VHDL file ... not selected for default binding because it is out of date"


@ldm.eth  已写:

 

Yes, I recompiled ALL the Xilinx simulation libraries for Questa (Vivado -> Tools -> Compile Simulation Libraries -> Compile All Libraries for All Languagesa and All Families), but this did not help ...

As for the Questa, I have several versions installed on my PC - Questa 10.6d, Questa 10.7 ...

How does Questa knows what Xilinx libraries look for and there location? 

Where the questa_lib should be mapped to? Here is how it appears in the Questa Project:

1.jpg

As you can see, it appears as "empty"... Should it be so? Actually the "C:/Projects/xgs/ex2sim/2019-04-30/questa/" is the directory where the Vivado Project Simulation for Questa was exported to (Vivado -> Export for Simulation ...)

It looks to be related to another post created by you. Did you copy the new modelsim.ini created by compile_simlib (in the pre-compiled library location) to the simulation directory?

Here's the information about modelsim.ini search order extracting from Questasim User Guide.

Finds the modelsim.ini file by evaluating the following conditions:
o If the -modelsimini option is used, then the file path specified is used if it exists; else
o use $MODELSIM (which specifies the directory location and name of a modelsim.ini file) if it exists; else
o use $(MGC_WD)/modelsim.ini; else
o use ./modelsim.ini; else
o use $(MODEL_TECH)/modelsim.ini; else
o use $(MODEL_TECH)/../modelsim.ini; else
o use $(MGC_HOME)/lib/modelsim.ini; else
o set path to ./modelsim.ini even though the file does not exist
Environment Variables used: MODELSIM, MGC_WD, MGC_HOME
You can determine which modelsim.ini file was used by executing the where command.

As for questa_lib, this is neither a standard library nor a Xilinx simulation library. As anwered in the other post, I don't think it's necessary. Is it referenced and used in your simulation script?

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Highlighted
Explorer
Explorer
868 Views
Registered: ‎01-15-2019

回复: [Questa] (vopt-1127) Error message - "VHDL file ... not selected for default binding because it is out of date"

"Did you copy the new modelsim.ini created by compile_simlib (in the pre-compiled library location) to the simulation directory?" - honestly, I don't remember ... Should I? How could this affect to the "out of date" error?

"As answered in the other post" - could you please provide a link to this post? 

 

0 Kudos
Highlighted
Teacher
Teacher
857 Views
Registered: ‎07-09-2009

Re: [Questa] (vopt-1127) Error message - "VHDL file ... not selected for default binding because it is out of date"

Question for my knowledge,
is c_counter_binary_v12_0_12 a unisim library
<== If this was helpful, please feel free to give Kudos, and close if it answers your question ==>
0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
845 Views
Registered: ‎07-16-2008

回复: [Questa] (vopt-1127) Error message - "VHDL file ... not selected for default binding because it is out of date"

@ldm.eth 

Here's the other post I mentioned.

https://forums.xilinx.com/t5/Simulation-and-Verification/Migration-of-Questa-Project-from-one-PC-to-another-gt-Error-vopt/m-p/969035#M25830

You have to ensure the currently mapped libraries are up-to-date. If the simulation references libraries from legacy modelsim.ini, I think there'll be similar out of date complaint.

 

@drjohnsmith 

It is an IP library.

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------