UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Explorer
Explorer
3,035 Views
Registered: ‎07-29-2009

Reduce size of simulation

I am simulating for a long time with the BFM in 2016.4 version of Vivado.

My btree file is over 81 GB in the xsim directory

My simulate.log is 4.4G

the wdb which is 8 G

and the file I'm writing to, which is right, is 1.9 GB

 

My simulation is terminating since it's out of HD space.  How do I stop the sim from writing to btree and set a limit on simulate.log in the "launch_simulation" command?  Is there a different way to simulate from the command line to limit the size of these files?


Regards,

Kurt

Tags (1)
0 Kudos
6 Replies
Explorer
Explorer
3,031 Views
Registered: ‎07-29-2009

Re: Reduce size of simulation

OK, I found this in the manual which controls 1 of the three:

 

In the Project Settings dialog box:

a. Click the Simulation category.

b. Select the Simulation tab.

c. Next to xsim.simulate.xsim.more_options add -maxlogsize where is the maximum amount of text output in megabytes.

 

One down - two to go.... Anyone?

Tags (1)
0 Kudos
Moderator
Moderator
2,950 Views
Registered: ‎04-24-2013

Re: Reduce size of simulation

Hi @petersk,

 

The .btree file is a temporary file that is used to build the wdb. The simplest method to reduce the size of it is to reduce the number of signals that are being simulated, along with the time the simulation is being run for. Understandably this isn't always possible.

 

What may help is to use the wdb file and the wcfg files to view the saved simulation data with the following command

 

xsim name.wdb -view name.wcfg -gui

 

It won't help with the file sizes but may give you a boost in speed as you are not rerunning simulations.

 

Best Regards
Aidan

 

 

------------------------------------------------------------------------------------------------------------------
Please mark the Answer as "Accept as solution" if this answered your question
Give Kudos to a post which you think is helpful and may help other users
------------------------------------------------------------------------------------------------------------------

------------------------------------------------------------------------------------------------------------------
Please mark the Answer as "Accept as solution" if this answered your question
Give Kudos to a post which you think is helpful and may help other users
------------------------------------------------------------------------------------------------------------------
0 Kudos
Explorer
Explorer
2,898 Views
Registered: ‎07-29-2009

Re: Reduce size of simulation

I tried to reduce the number of signals with:

 relaunch_sim

 log_wave /tb/tb_ACLK

 run all

 

Unfortunately, it seems like the wdb file runs at the same rate!

Why isn't that shrinking the file?

0 Kudos
Xilinx Employee
Xilinx Employee
2,865 Views
Registered: ‎09-25-2014

Re: Reduce size of simulation

Hi @petersk,

 

Can you check in simulation settings under simulation tab , "xsim.simulate.log_all_signals*"    option is unchecked?

sim.JPG

 

0 Kudos
Explorer
Explorer
2,831 Views
Registered: ‎07-29-2009

Re: Reduce size of simulation

No, it is not checked.  Any other thoughts?

 

I am now trying to export simulation.  What is a way that I could limit the wdb size through the same kind of tcl command for that?

0 Kudos
Explorer
Explorer
2,824 Views
Registered: ‎07-29-2009

Re: Reduce size of simulation

Is there any way to stop btree from being so large.  It's really killing me!  Google tells me very little about it and your docs don't show how it is used and reduced.

Kurt

Tags (1)
0 Kudos