cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Jennifer_Holt
Visitor
Visitor
385 Views
Registered: ‎06-02-2020

Segfault when running simulation. 2020.2

Hi,

I am trying to improve my testbenches and am basing my efforts on some guides from https://verificationguide.com/

Specifically I am trying to duplicate the following in vivado 2020.2: https://www.edaplayground.com/x/2527

I created the files and made a simple project, however when I try to simulate it, I get the following error:

Compiling package xil_defaultlib.$unit_design_sv
ERROR: [XSIM 43-3316] Signal SIGSEGV received.
Printing stacktrace...

[0] /data/opt/Xilinx/Vivado/2020.2/bin/unwrapped/lnx64.o/xelab() [0x539afd]
[1] /data/opt/Xilinx/Vivado/2020.2/bin/unwrapped/lnx64.o/xelab() [0x646536]
[2] /data/opt/Xilinx/Vivado/2020.2/bin/unwrapped/lnx64.o/xelab() [0x64a546]
[3] /data/opt/Xilinx/Vivado/2020.2/bin/unwrapped/lnx64.o/xelab() [0x64a887]
[4] /data/opt/Xilinx/Vivado/2020.2/bin/unwrapped/lnx64.o/xelab() [0x6582e0]
[5] /data/opt/Xilinx/Vivado/2020.2/bin/unwrapped/lnx64.o/xelab() [0x66cb21]
[6] /data/opt/Xilinx/Vivado/2020.2/bin/unwrapped/lnx64.o/xelab() [0x79d03f]
[7] /data/opt/Xilinx/Vivado/2020.2/bin/unwrapped/lnx64.o/xelab() [0x79de38]
[8] /data/opt/Xilinx/Vivado/2020.2/bin/unwrapped/lnx64.o/xelab() [0x54a7de]
[9] /data/opt/Xilinx/Vivado/2020.2/bin/unwrapped/lnx64.o/xelab() [0x981dd5]
[10] /data/opt/Xilinx/Vivado/2020.2/bin/unwrapped/lnx64.o/xelab() [0x94b150]
[11] /data/opt/Xilinx/Vivado/2020.2/bin/unwrapped/lnx64.o/xelab() [0x51faa2]
[12] /data/opt/Xilinx/Vivado/2020.2/bin/unwrapped/lnx64.o/xelab() [0x5355e9]
[13] /data/opt/Xilinx/Vivado/2020.2/bin/unwrapped/lnx64.o/xelab() [0x4b7f54]
[14] /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xe7) [0x7fc1d9bc5bf7]
[15] /data/opt/Xilinx/Vivado/2020.2/bin/unwrapped/lnx64.o/xelab() [0x51e3b7]

I am using Vivado 2020.2 on Ubuntu 18.04. I have attached the archived project.

Thanks,

Jenn Holt

 

0 Kudos
1 Reply
bandi
Moderator
Moderator
291 Views
Registered: ‎09-15-2016

Hi @Jennifer_Holt ,

Thanks  for sharing the test case. I have reported this issue to the factory.

Thanks & Regards,
Sravanthi B
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------