cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
pstarbitsim
Contributor
Contributor
641 Views
Registered: ‎10-09-2018

Simulator GUI waveform misaligned

Jump to solution

Hi,

I have used the vivado simulator quite often, but now I got something I have never seen before, and I have no clue how to solve it. As you can see in the picture below are the waveforms slightly less in height than the labels, causing them to misalign.

In this screenshot there are not many signals and one can figure out which label is for which signal, but when there are more it is almost undoable, and takes way too much time. I tried finding font-size settings, but I cannot find any settings related to the height.

Can someone point me in the right direction?

pstarbitsim_0-1611933908147.png

 

0 Kudos
1 Solution

Accepted Solutions
pstarbitsim
Contributor
Contributor
451 Views
Registered: ‎10-09-2018

A collegue suggested removing a lot of configuration files, such as .Xil and .bashrc.

That solved the problem and I went about trying to reproduce the problem and succeeded when I set the font scaling in Vivado to 90%.

So not setting that will mean more scrolling, and less overview, but at least the simulation waveforms align again.

View solution in original post

0 Kudos
4 Replies
miti
Xilinx Employee
Xilinx Employee
565 Views
Registered: ‎06-10-2020

@pstarbitsim ,

Can you please provide which OS and which vivado version you are using.

0 Kudos
pstarbitsim
Contributor
Contributor
516 Views
Registered: ‎10-09-2018

Sorry completely forgot to add that info:

Ubuntu 18.04

Vivado 19.1

0 Kudos
pstarbitsim
Contributor
Contributor
474 Views
Registered: ‎10-09-2018

Just checked with 19.2, same problem there

0 Kudos
pstarbitsim
Contributor
Contributor
452 Views
Registered: ‎10-09-2018

A collegue suggested removing a lot of configuration files, such as .Xil and .bashrc.

That solved the problem and I went about trying to reproduce the problem and succeeded when I set the font scaling in Vivado to 90%.

So not setting that will mean more scrolling, and less overview, but at least the simulation waveforms align again.

View solution in original post

0 Kudos