UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Explorer
Explorer
226 Views
Registered: ‎01-15-2019

Some files doesn't appear under Similation Sources, but they are set to be used in Simulation... How to fix?

Hi All,

How can I create another files set for simulations?

Some files, which are defined to be used in simulation set, doesn't appear under the simulation set... Why?

As you can see below, the xgs_top.v is set to be used also in Simulation, but it doesn't appear under Simulation Sources ... Why?


1.jpg2.jpg


Thank you!

 

0 Kudos
3 Replies
Xilinx Employee
Xilinx Employee
196 Views
Registered: ‎07-16-2008

回复: Some files doesn't appear under Similation Sources, but they are set to be used in Simulation... How to fix?

Is is seen under the top level hierarchy in Design Sources, or is it in Non-Module files?

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Explorer
Explorer
182 Views
Registered: ‎01-15-2019

Some files doesn't appear under Similation Sources, but they are set to be used in Simulation... How to fix?

 

All the files are under Design Sources (not under the Non-Module files section), all the files are set to be used in the simulation, but they are not appear under the Simulation sources section...

I remember I selected by mistake some wrong file to be a Top of the Simulation Sources... Since then all the RTL files just dismissed from theSimulation Sources... So, how to bring them there again?

 

0 Kudos
Explorer
Explorer
168 Views
Registered: ‎01-15-2019

Re: Some files doesn't appear under Similation Sources, but they are set to be used in Simulation... How to fix?

 

How can I remove ALL the simulation sources from my Project and then add them according to the Design Sources?

 

0 Kudos