UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor xliu79
Visitor
194 Views
Registered: ‎05-31-2018

Static waveform signal missing

HI.

I was running emulation with SDSOC 2018.2, and I want to record the static waveform for further analysis. I logged wave by using the command 

log_wave -r {/zcu102_wrapper/zcu102_i} 

And exactly see waveform logged and shown in the simulation waveform window. The simulation is pretty long, and the saved wdb file is around 300 GB.

However, when I reopen the wdb file, I find out that 

1) some signals are missing: after the signal is added into the waveform panel, the signal is blank

2) some signals stop to change after some time. The signal remains at 0 or 1 for all rest of the time.

I want to know how do save the wdb file properly without losing simulation information.

 

0 Kudos
1 Reply
Moderator
Moderator
97 Views
Registered: ‎09-15-2016

Re: Static waveform signal missing

Hi @xliu79

Can you please try running the below command to log signals into WDB file:

log_wave -r {/zcu102_wrapper/zcu102_i}  -verbose 

Please check if there are any warnings stating log_wave skipped an HDL object or scope because of some problem.

In previous simulation run make sure you ran the simulation of your project after adding all the signals to the waveform viewer and it shows all the signals and their outputs before logging the waveforms to the database file for static simulation. 

Then save and try opening the WDB file in static simulation, add waves to the waveform viewer and check if you are facing any issues.

OR you can try saving the waveform configuration file .wcfg along with the .wdb in previous simulation then try opening the static simulation and open already saved .wdb and .wcfg files in it and check if you are facing any issues.

Please note that in static simulation mode you cannot use commands that control or monitor a simulation, such as run commands, as there is no underlying ‘live’ simulation model to control. However, you can view waveforms and the HDL design hierarchy in a static simulation. 

For more information, please refer the below user guide chapter-5:

https://www.xilinx.com/support/documentation/sw_manuals/xilinx2018_3/ug900-vivado-logic-simulation.pdf

Thanks & Regards,
Sravanthi B
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos