UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Explorer
Explorer
2,440 Views
Registered: ‎07-29-2009

Vivado 2016.4 crash

I was running a long simulation that writes a large file.  Before the sim ended, Vivado crashes and i get this message:

terminate called after throwing an instance of 'std::ios_base::failure'
  what():  basic_ios::clear
Abnormal program termination (6)
Please check '/home/.../hs_err_pid4448.log' for details

 

The file isn't completely closed and the log file has nothing in it.

 

This has to do with the BFM creating a HUGE vivado.log (4.9 GB).  And the disk became full.  Is there a way to suppress the BFM from writing to the log?

 

And how do I stop it from writing to the wdb file as well?

 

I found

vivado -nolog -nojournal

 

but how do I also turn off simulate.log in the behav directory?

 

Regards,

Kurt

Tags (1)
0 Kudos
2 Replies
Xilinx Employee
Xilinx Employee
2,378 Views
Registered: ‎08-01-2008

Re: Vivado 2016.4 crash

check this ARs for known use cases for crash
https://www.xilinx.com/support/answers/55854.html
Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
Explorer
Explorer
2,360 Views
Registered: ‎07-29-2009

Re: Vivado 2016.4 crash

I know why it crashed.  The HD was full.  I'm looking for solutions to not fill up the HD by turning off logs and the database file (WDB).

0 Kudos