UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor naeim35
Visitor
1,179 Views
Registered: ‎03-12-2018

Vivado 2017.4 Modelsim verification License

Hi all,

 

I have created a TestBench which includes the AXI VIPs blocks using Vivado 2017.4. When I start SIMULATION the ModelSim runs but then I encounter with this ERROR message:

 

# Loading xilinx_vip.axi_vip_pkg
# Loading xilinx_vip.axi_vip_if_sv_unit
# Loading xilinx_vip.axi_vip_if
# Loading xilinx_vip.axi_vip_axi4pc
# Loading work.gash_axi_vip_1_0
# ** Error: (vsim-1) Unable to checkout verification license - testbench generation feature (randomize, randcase, randsequence, covergroup) is only supported with QuestaSim.
#    Time: 0 ps  Iteration: 0  Instance: /gash_tb File: ../../../../gash_tb.srcs/sources_1/new/gash_tb.sv
# Error loading design
# Error: Error loading design
#        Pausing macro execution
# MACRO ./gash_tb_simulate.do PAUSED at line 9

 

My question is that if ModelSim PE 10.5a supports the AXI VIPs? Is there any solution for this problem?

 

Best regards,

 

Naeim

0 Kudos
2 Replies
Scholar richardhead
Scholar
1,173 Views
Registered: ‎08-01-2012

Re: Vivado 2017.4 Modelsim verification License

You need to buy a full QuestaSim Licence to run an SV testbench with randomisation and coverage in it (which will cover the AXI VIPs)

0 Kudos
Visitor naeim35
Visitor
1,158 Views
Registered: ‎03-12-2018

Re: Vivado 2017.4 Modelsim verification License

Thank you for the quick reply.

Br,
Naeim
0 Kudos