cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Observer
Observer
270 Views
Registered: ‎01-28-2015

Vivado 2019.1 Generating Incorrect Relative Paths for Modelsim .do files

Hi,

I am using Vivado 2019.1 with Modelsim 2020.3 on Windows 10.

When I select Modelsim as my simulator and run the "launch_simulation" TCL command I get an error stating certain files cannot be read. Upon opening the compile.do script (that Vivado generates) I noticed file paths that were completely incorrect (e.g. extra "../" or circular references to folders). I found a workaround by running the "export_simulation" TCL command using absolute paths. After running the provided .sh file in the newly generated modelsim folder (that Vivado created) the simulation works perfectly.

Is there a step that I am missing? Is there a way to enforce absolute paths without running the "export_simulation" TCL command?

Thanks,

Ari

Tags (2)
0 Kudos
3 Replies
Highlighted
Xilinx Employee
Xilinx Employee
234 Views
Registered: ‎07-16-2008

Please refer to launch_simulation -help. You can specify -absolute_path option to  generate absolute paths for the source files in the generated script files.

-absolute_path - (Optional) Specify this option to define the source and
include paths used in the simulation scripts as absolute paths. By default,
all paths are written as relative to the simulation run directory. Relative
paths include an "origin_dir" variable that is set in the simulation script
to the current run directory, but you can edit the $origin_dir variable to
point to a path of your choice when relocating the design and simulation
scripts.

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Highlighted
Observer
Observer
143 Views
Registered: ‎01-28-2015

The -absolute_path option worked except it now looks for hte Modelsim_lib folder instead of questa_lib folder (as I mentioned in this post).

Any ideas how to get Vivado to point to the correct folder?

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
118 Views
Registered: ‎07-16-2008

I can reproduce the issue with launch_simulation -absolute_path. I'll file a bug report to dev team.

For now, you can either edit the compile.do to correct the path to questa_lib, or rename the directory name to modelsim_lib.

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos