cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
885 Views
Registered: ‎03-03-2011

Vivado can't find Questasim

Hello all,

I can't find a solution to this. I've set all the paths in the GUI for Vivado to find Questasim. I'm sure its there, I can source the QuestaSim environment and call Vsim. I can even launch a simulation from Vivado for a simple adder, but I can't get the simulation libraries to compile.

Here's the tcl call that vivado generates:

compile_simlib -simulator questa -simulator_exec_path {/media/me/HDD/QUESTA-CORE-PRIME_10.5c-4/questasim/bin} -family virtex7 -family virtexuplus -family zynquplus -language all -library all -dir {/media/me/HDD/QUESTA-CORE-PRIME_10.5c-4}

And the resulting error:

ERROR: [Vivado 12-3754] Failed to find the 'questasim' simulator executable. Make sure to set the 'questasim' installation environment and retry this command to compile the libraries for this simulator. For more information on tool setup refer 'questasim' user guide

I've tried other directories as well, such as:

/media/me/HDD/QUESTA-CORE-PRIME_10.5c-4/questasim/

/media/me/HDD/QUESTA-CORE-PRIME_10.5c-4/

/media/me/HDD/QUESTA-CORE-PRIME_10.5c-4/questasim/linux_x86_64

/media/me/HDD/QUESTA-CORE-PRIME_10.5c-4/questasim/linux

I get the same results. Any ideas?

Thanks

 

0 Kudos
3 Replies
Highlighted
Moderator
Moderator
856 Views
Registered: ‎05-31-2017

Hi @bandit,

You can try " which vsim "command in terminal to get the path of vsim executables and point that path in the compile_simlib command.

0 Kudos
Highlighted
Adventurer
Adventurer
842 Views
Registered: ‎03-03-2011

Hello,

I'd done that, it was one of the paths I tried.

Regards

0 Kudos
Highlighted
Moderator
Moderator
796 Views
Registered: ‎05-31-2017

HI @bandit,

Can you once please try setting the environment variable in terminal an invoke vivado for compiling simulation libraries from the same terminal itself?

setenv PATH /media/me/HDD/QUESTA-CORE-PRIME_10.5c-4/questasim/linux_x86_64/:${PATH}

0 Kudos