cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
paebbels
Explorer
Explorer
2,219 Views
Registered: ‎04-24-2014

Vivado doesn't properly escape paths with spaces

Jump to solution

Hello,

 

according to AR #52981, the problem was solved. However, I can reproduce the issue in Vivado 2017.x!

Any comments from Xilinx how a solved bug can occur again?

 

In my case, it's a WCFG file conaining spaces, that can't be loaded after saving and adding it to the project.

 

 

Kind regards

    Patrick

0 Kudos
1 Solution

Accepted Solutions
graces
Moderator
Moderator
3,836 Views
Registered: ‎07-16-2008

I ran a test at my end. If the .wcfg filename contains space, it cannot be loaded automatically when launching simulation. However, it can still be opened successfully after simulation is launched.

 

The fix in the mentioned AR mainly deals with the corrupt path separator by adding curly braces around --view option in xsim command. It looks when space is found, it's still interpreted as the end of filename.

I'll provide the feedback to the dev team. Thanks for reporting this to us.

Currently please avoid using spaces.

-----------------------------------------------------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
If starting with Versal take a look at our Versal Design Process Hub and our Versal Blogs.
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
1 Reply
graces
Moderator
Moderator
3,837 Views
Registered: ‎07-16-2008

I ran a test at my end. If the .wcfg filename contains space, it cannot be loaded automatically when launching simulation. However, it can still be opened successfully after simulation is launched.

 

The fix in the mentioned AR mainly deals with the corrupt path separator by adding curly braces around --view option in xsim command. It looks when space is found, it's still interpreted as the end of filename.

I'll provide the feedback to the dev team. Thanks for reporting this to us.

Currently please avoid using spaces.

-----------------------------------------------------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
If starting with Versal take a look at our Versal Design Process Hub and our Versal Blogs.
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos