cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
kinkeads
Adventurer
Adventurer
3,587 Views
Registered: ‎12-20-2010

XSIM 43-3241 error: gthe4_channel_002.vp Node SIM_VERSION is not annotated

Jump to solution

Xsim generates the following error during elaboration of my design.   The design contains a Chip2Chip bridge using GTH transceivers.   The simulation testbench is written in System Verilog.

 

ERROR: [XSIM 43-3241] File /wrk/2017.1/nightly/2017_04_14_1846317/data/secureip/gthe4_channel/gthe4_channel_002.vp, Line Num 22892, Node SIM_VERSION is not annotated.

 

 

0 Kudos
1 Solution

Accepted Solutions
kinkeads
Adventurer
Adventurer
5,630 Views
Registered: ‎12-20-2010

After opening a support ticket, I was told this is a known bug and will be fixed in 2017.3.

 

There is a work-around.  The error only occurs during mixed-mode simulations.  Set the target language to Verilog and regenerate all the outputs so there are no VHDL source files, and then simulation should run.

View solution in original post

0 Kudos
3 Replies
vijayak
Xilinx Employee
Xilinx Employee
3,548 Views
Registered: ‎10-24-2013

Hi @kinkeads

 

Please check if the following AR is applicable to you.

https://www.xilinx.com/support/answers/63972.html

Thanks,Vijay
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
kinkeads
Adventurer
Adventurer
3,531 Views
Registered: ‎12-20-2010

AR 63972 recommends overriding the SIM_VERSION parameter value, but I do not see this property on any devices in my IP Integrator block design.

 

Is SIM_VERSION a property attached to an IP block?  I would expect it to be on the AURORA_64B66B IP block since it contains the GT transceivers.

Thanks!

 

 

0 Kudos
kinkeads
Adventurer
Adventurer
5,631 Views
Registered: ‎12-20-2010

After opening a support ticket, I was told this is a known bug and will be fixed in 2017.3.

 

There is a work-around.  The error only occurs during mixed-mode simulations.  Set the target language to Verilog and regenerate all the outputs so there are no VHDL source files, and then simulation should run.

View solution in original post

0 Kudos