UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Explorer
Explorer
220 Views
Registered: ‎09-13-2011

Xsim stopped working properly

When I installed Vivado 2019.1 everything worked. I stopped seeing the Xsim "can't recover database" error that I often got in 2018.3 where the solution was to delete the xsim (or .xsim) folder under sim and start over.

But now I'm seeing two things wrong. The "can't recover" error is back and worse the simulator has stopped compiling changed files so if I make a change I need to delete the xsim folder and restart simulation completely.

Since I'm not using xsim every day I can't tell if the trouble came after a major Windows 10 update or after I installed the 2019.1 update 3. But result is that Xsim has become defunctional for me.

Any suggestions?

0 Kudos
2 Replies
Moderator
Moderator
182 Views
Registered: ‎05-31-2017

Re: Xsim stopped working properly

Hi @tsjorgensen ,

Can you please share the complete error which you are facing in XSIM ? Please attach a snippet of the error.

When are you facing the error, I mean once the waveform window gets opened or after running simulation after some time or during the elaboration phase ?

Can you just try simulating on an example design, and see if you see the issue there too i.e., if the compiler compiles the modified files or not ?

Also, disable the Incremental Compilation from Settings --> Simulation --> Advanced --> disable the Incremental Simulation and see if you still see the same issue.

 

0 Kudos
Explorer
Explorer
141 Views
Registered: ‎09-13-2011

Re: Xsim stopped working properly

Error is like this (with different files and different simulations)

INFO: [VRFC 10-163] Analyzing VHDL file "mydir/trunk/2_components/fm_section/fm_section.vhd" into library xil_defaultlib
ERROR: [VRFC 10-3006] 'mydir/trunk/project/pl_top_pcap_prj/pl_top_pcap_prj.sim/sim_1/behav/xsim/xsim.dir/xil_defaultlib/switch_matrix_p.vdb' needs to be re-saved since 'xil_defaultlib.definitions_p' changed
ERROR: [VRFC 10-3032] 'xil_defaultlib.switch_matrix_p' failed to restore
ERROR: [VRFC 10-2987] 'switch_matrix_p' is not compiled in library 'xil_defaultlib' [mydir/trunk/2_components/fm_section/fm_section.vhd:120]
INFO: [VRFC 10-3107] analyzing entity 'fm_section'
ERROR: [VRFC 10-3782] unit 'fm_section' ignored due to previous errors [mydir/trunk/2_components/fm_section/fm_section.vhd:123]

I have re-installed 2019.1 and so far no problems. Will try to add the third update and see if that changes anything.

0 Kudos