cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Participant
Participant
1,369 Views
Registered: ‎09-30-2015

compile_simlib ignores -library option

Jump to solution

We're running into an issue with the compile_simlib command. We're using 2017.3.1, but this issue has been 

around for the last couple of releases.

 

When using the following tcl command:

 

        compile_simlib -library unisim -dir ./mpsoc_libs_modelsim -simulator modelsim -simulator_exec_path /tools/ModelSim/10.6c_32/modelsim_dlx/bin -32bit -verbose -family zynquplus

 

... we find that compile_simlib ignores the -library option and compiles all of the libraries.

 

The bizarre thing is that when the command is executed, the output seems to indicate that it did see the -library option:

 

vivado -mode tcl -source compile_mpsoc_modelsim_libs.tcl

****** Vivado v2017.3.1 (64-bit)
**** SW Build 2035080 on Fri Oct 20 14:20:00 MDT 2017
**** IP Build 2034413 on Fri Oct 20 15:56:25 MDT 2017
** Copyright 1986-2017 Xilinx, Inc. All Rights Reserved.

source compile_mpsoc_modelsim_libs.tcl
# compile_simlib -library unisim -dir ./mpsoc_libs_modelsim -simulator modelsim -simulator_exec_path /tools/ModelSim/10.6c_32/modelsim_dlx/bin -32bit -verbose -family zynquplus
INFO: [Vivado 12-4753] Extracting data from the IP repository...(this may take a while, please wait)...
.......................................................................................................
.......................................................................................................
.......................................................................................................
.......................................................................................................
.......................................................................................................
.......................................................................................................
.......................................................................................................
..................................................................
INFO: [setup_ip_static_library-Tcl-23] Data extracted from repository. Inspected 393 IP libraries.

> Current directory :- '/vault/Releases/rio4_brc1_4x_serial_endpoint_core_mpsoc_source_11_09_17/RapidIO_1x-4x_LP-Serial_Endpoint/testbench'
> Library data paths:- '/tools/Xilinx/Vivado/2017.3/data'
'/tools/Xilinx/Vivado/2017.3/ids_lite/ISE'
> Device family(s) :- 'zynquplus'
> Library(s) :- 'unisim'
> Language(s) :- 'vhdl, verilog'
> Compilation mode :- '32-bit'

 

Has anyone else seen this? The libraries are compiled correctly, but compiling all of the libraries takes a looooong time.

 

Thanks

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Xilinx Employee
Xilinx Employee
1,900 Views
Registered: ‎07-16-2008

Re: compile_simlib ignores -library option

Jump to solution

The following values are shown in the help manual for -library option.

 

* all (the default)

* unisim

* simprim

 

The IP and secureip libraries will be compiled anyway. If you want to bypass the static IP library compilation, you need to add -no_ip_compile option.

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

2 Replies
Highlighted
Xilinx Employee
Xilinx Employee
1,901 Views
Registered: ‎07-16-2008

Re: compile_simlib ignores -library option

Jump to solution

The following values are shown in the help manual for -library option.

 

* all (the default)

* unisim

* simprim

 

The IP and secureip libraries will be compiled anyway. If you want to bypass the static IP library compilation, you need to add -no_ip_compile option.

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

Highlighted
Participant
Participant
1,338 Views
Registered: ‎09-30-2015

Re: compile_simlib ignores -library option

Jump to solution

Thanks

 

I didn't see that option when I looked at AR# 64083.

 

Kent

0 Kudos