UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Explorer
Explorer
5,971 Views
Registered: ‎04-11-2010

error in modelsim from project navigator

i get this error when i am trying to run modelsim from project navigator. I compiled complxib and tried to run the simulation.

 

ERROR: Simulator version mismatch!
               The simulation libraries were compiled for the 'MTI_PE 6.6b' version, but
               the selected simulator is 'MTI_PE Edition'. Please recompile the libraries for
               the selected simulator version or change the simulator selection.

 

How can i change the selected simulator  to MTI_PE 6.6 b .  The only option in the xilinx ise 12.1 is Modelsim -pe -vhdl but cant fined the version number option.

0 Kudos
5 Replies
Xilinx Employee
Xilinx Employee
5,961 Views
Registered: ‎08-02-2007

Re: error in modelsim from project navigator

 

have you set correct path for modelsim PE in EDIT- preference intregrated Tools?

 

------------------------------------------------------------------------------
Don't forget to reply, give kudo and accept as solution
------------------------------------------------------------------------------
0 Kudos
Explorer
Explorer
5,953 Views
Registered: ‎04-11-2010

Re: error in modelsim from project navigator

How do i do that?

 

 

I did set the simulator path while compiling HDL simulation libraries.

Also i have included simulator as modelsim -PE VHDL in Project-> Design properties.

 

 

I dont see modelsim -PE vhdl 6.6 b... ?

0 Kudos
Newbie poutchou24
Newbie
5,826 Views
Registered: ‎08-03-2010

Re: error in modelsim from project navigator

I have the same problem, need heeeeeeelp

0 Kudos
Historian
Historian
5,816 Views
Registered: ‎02-25-2008

Re: error in modelsim from project navigator

 


@abdullahansari wrote:

i get this error when i am trying to run modelsim from project navigator. I compiled complxib and tried to run the simulation.

 

ERROR: Simulator version mismatch!
               The simulation libraries were compiled for the 'MTI_PE 6.6b' version, but
               the selected simulator is 'MTI_PE Edition'. Please recompile the libraries for
               the selected simulator version or change the simulator selection.

 

How can i change the selected simulator  to MTI_PE 6.6 b .  The only option in the xilinx ise 12.1 is Modelsim -pe -vhdl but cant fined the version number option.


You need to call your Mentor Graphics representative and buy ModelSim PE. It is not free. (It's about ten kilobucks.)

 

----------------------------Yes, I do this for a living.
0 Kudos
Xilinx Employee
Xilinx Employee
5,773 Views
Registered: ‎11-16-2007

Re: error in modelsim from project navigator

Hi,

 

You need to set the simulator path in ISE. Go to Edit menu => Preferences...=> Integrated tools as shown in the attachment. 

Apart from this if you can also try, Right click on the 'Simulate Behavioral Model' and uncheck "Ignore Pre-Compiled Library Compilation Message"

 

Thanks,

Thanks,
-PK
pref.JPG
0 Kudos