UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Explorer
Explorer
189 Views
Registered: ‎12-05-2016

error in simulation : [VRFC 10-704] formal uart_rx has no actual or default value

Jump to solution

Hi all,

I got the attached error while doing simulation. When I checked UART_RX is a top level input and it is correctly port mapped to an internal module. then why the tool is throwing this error? 

port map section

--------------------------------

uart : UART_Wrapper
Port map (clk_uart => clkToUart,-- 10MHz
tx_out => UART_TX,
rx_in => UART_RX,
--- reset => gt0_tx_system_reset_c,
rd_cnt => fifo_rd_cnt,
wr_cnt => fifo_wr_cnt,
fifo_data => fifo_data1,
fifo_read => fifo_rd_en,
tx_clk => gt0_txusrclk2_i);

------------------------------------------------

I was able to generate the bit file. 

Any help is appreciated. 

 

no_formal.JPG
0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
160 Views
Registered: ‎07-16-2008

回复: error in simulation : [VRFC 10-704] formal uart_rx has no actual or default value

Jump to solution

If it passes in synthesis, did you drive it in testbench if this is a top level input port?

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
2 Replies
Xilinx Employee
Xilinx Employee
161 Views
Registered: ‎07-16-2008

回复: error in simulation : [VRFC 10-704] formal uart_rx has no actual or default value

Jump to solution

If it passes in synthesis, did you drive it in testbench if this is a top level input port?

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
Explorer
Explorer
127 Views
Registered: ‎12-05-2016

回复: error in simulation : [VRFC 10-704] formal uart_rx has no actual or default value

Jump to solution
Exactly. I missed it in the test bench. I was looking at only design sources.
Thank you.
0 Kudos